summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-audiorecorder/vdr-audiorecorder-0.1.0_pre14-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-audiorecorder/vdr-audiorecorder-0.1.0_pre14-r2.ebuild')
-rw-r--r--media-plugins/vdr-audiorecorder/vdr-audiorecorder-0.1.0_pre14-r2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-plugins/vdr-audiorecorder/vdr-audiorecorder-0.1.0_pre14-r2.ebuild b/media-plugins/vdr-audiorecorder/vdr-audiorecorder-0.1.0_pre14-r2.ebuild
new file mode 100644
index 000000000000..ddaf08ccbf41
--- /dev/null
+++ b/media-plugins/vdr-audiorecorder/vdr-audiorecorder-0.1.0_pre14-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit vdr-plugin-2 flag-o-matic
+
+MY_P=${P/_pre/-pre}
+
+DESCRIPTION="VDR plugin: automatically record radio-channels and split it into tracks according to RadioText-Info"
+HOMEPAGE="http://www.a-land.de/audiorecorder/"
+SRC_URI="http://www.zulu-entertainment.de/files/${PN}/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+S=${WORKDIR}/${MY_P#vdr-}
+
+DEPEND=">=media-video/vdr-1.6.0
+ media-libs/taglib
+ virtual/ffmpeg[encode,mp3]
+ >=dev-libs/tinyxml-2.6.1[stl]"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-shared-tinyxml.diff"
+
+ vdr-plugin-2_src_prepare
+
+ sed -i "s:include <avcodec.h>:include <libavcodec/avcodec.h>:" convert.h audiorecorder.c
+ sed -i "s:RegisterI18n:// RegisterI18n:" audiorecorder.c
+
+ # UINT64_C is needed by ffmpeg headers
+ append-cxxflags -D__STDC_CONSTANT_MACROS
+
+ epatch "${FILESDIR}/${P}_obsolete-i18n.diff"
+ epatch "${FILESDIR}/${P}-ffmpeg-1.patch"
+ epatch "${FILESDIR}/${P}-libav9.patch"
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+ keepdir /var/vdr/audiorecorder
+ chown -R vdr:vdr "${D}"/var/vdr
+
+ insinto /etc/vdr/plugins/audiorecorder
+ doins "${S}"/contrib/audiorecorder.conf
+}