summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2019-12-27 17:22:07 +0100
committerJoerg Bornkessel <hd_brummy@gentoo.org>2019-12-27 17:22:42 +0100
commit9b6d70e58a0dfe1bb1b4a526eea92d5b4c87c0cd (patch)
treecd9966de2962ef770ae90bad2bffe03736e09c0d /media-plugins/vdr-dvdswitch/vdr-dvdswitch-0.2.3.ebuild
parentdev-python/cssutils: Python 3.8 (diff)
downloadgentoo-9b6d70e58a0dfe1bb1b4a526eea92d5b4c87c0cd.tar.gz
gentoo-9b6d70e58a0dfe1bb1b4a526eea92d5b4c87c0cd.tar.bz2
gentoo-9b6d70e58a0dfe1bb1b4a526eea92d5b4c87c0cd.zip
media-plugins/vdr-dvdswitch: bump
Bug: https://bugs.gentoo.org/703968 Closes: https://bugs.gentoo.org/703968 Package-Manager: Portage-2.3.83, Repoman-2.3.18 Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
Diffstat (limited to 'media-plugins/vdr-dvdswitch/vdr-dvdswitch-0.2.3.ebuild')
-rw-r--r--media-plugins/vdr-dvdswitch/vdr-dvdswitch-0.2.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-plugins/vdr-dvdswitch/vdr-dvdswitch-0.2.3.ebuild b/media-plugins/vdr-dvdswitch/vdr-dvdswitch-0.2.3.ebuild
new file mode 100644
index 000000000000..e20d6e3795c6
--- /dev/null
+++ b/media-plugins/vdr-dvdswitch/vdr-dvdswitch-0.2.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vdr-plugin-2
+
+VERSION="2084" # every bump, new version
+
+DESCRIPTION="VDR Plugin: to play dvds and dvd file structures"
+HOMEPAGE="https://projects.vdr-developer.org/projects/plg-dvdswitch"
+SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-video/vdr"
+RDEPEND="media-plugins/vdr-dvd"
+
+DEFAULT_IMAGE_DIR="/var/vdr/video/dvd-images"
+
+VDR_CONFD_FILE="${FILESDIR}/0.1.3/confd-r2"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ sed -e "s:/video/dvd:${DEFAULT_IMAGE_DIR}:" -i setup.c
+}