summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-epgsearch/vdr-epgsearch-1.0.0-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-epgsearch/vdr-epgsearch-1.0.0-r1.ebuild')
-rw-r--r--media-plugins/vdr-epgsearch/vdr-epgsearch-1.0.0-r1.ebuild113
1 files changed, 113 insertions, 0 deletions
diff --git a/media-plugins/vdr-epgsearch/vdr-epgsearch-1.0.0-r1.ebuild b/media-plugins/vdr-epgsearch/vdr-epgsearch-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..dedffa212dbc
--- /dev/null
+++ b/media-plugins/vdr-epgsearch/vdr-epgsearch-1.0.0-r1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: Searchtimer and replacement of the VDR program menu"
+HOMEPAGE="http://winni.vdr-developer.org/epgsearch"
+
+case ${P#*_} in
+ rc*|beta*)
+ MY_P="${P/_/.}"
+ SRC_URI="http://winni.vdr-developer.org/epgsearch/downloads/beta/${MY_P}.tgz"
+ S="${WORKDIR}/${MY_P#vdr-}"
+ ;;
+ *)
+ SRC_URI="http://winni.vdr-developer.org/epgsearch/downloads/${P}.tgz"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="pcre tre linguas_de"
+
+DEPEND=">=media-video/vdr-1.3.45
+ pcre? ( dev-libs/libpcre )
+ tre? ( dev-libs/tre )"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="pcre? ( !tre )
+ tre? ( !pcre )"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ fix_vdr_libsi_include conflictcheck.c
+
+ if has_version ">=media-video/vdr-1.7.25"; then
+ epatch "${FILESDIR}/${P}_vdr-1.7.25.diff"
+ fi
+
+ if has_version ">=media-video/vdr-1.7.28"; then
+ sed -i "s:SetRecording(recording->FileName(), recording->Title:SetRecording(recording->FileName:" menu_searchresults.c
+ fi
+
+ if has_version ">=media-video/vdr-1.7.33"; then
+ epatch "${FILESDIR}/${P}_vdr-1.7.33.diff"
+ fi
+
+ epatch "${FILESDIR}/${P}_vdr-2.1.2.diff"
+
+ # disable automagic deps
+ sed -i Makefile -e '/^AUTOCONFIG=/s/^/#/'
+
+ if use pcre; then
+ einfo "Using pcre for regexp searches"
+ sed -i Makefile -e 's:^#REGEXLIB = pcre:REGEXLIB = pcre:'
+ fi
+
+ if use tre; then
+ einfo "Using tre for unlimited fuzzy searches"
+ sed -i Makefile -e 's:^#REGEXLIB = pcre:REGEXLIB = tre:'
+ fi
+
+ # install conf-file disabled
+ sed -e '/^Menu/s:^:#:' -i conf/epgsearchmenu.conf
+
+ # Get a rid of the broken symlinks
+ rm -f README{,.DE} MANUAL
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ diropts "-m755 -o vdr -g vdr"
+ keepdir /etc/vdr/plugins/epgsearch
+ insinto /etc/vdr/plugins/epgsearch
+
+ doins conf/epgsearchmenu.conf
+ doins conf/epgsearchconflmail.templ conf/epgsearchupdmail.templ
+
+ dodoc conf/*.templ
+
+ doman man/en/*.gz
+
+ if use linguas_de; then
+ doman -i18n=de man/de/*.gz
+ fi
+}
+
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.9.18"
+ previous_less_than_0_9_18=$?
+}
+
+pkg_postinst() {
+ vdr-plugin-2_pkg_postinst
+ if [[ $previous_less_than_0_9_18 = 0 ]] ; then
+ elog "Moving config-files to new location /etc/vdr/plugins/epgsearch"
+ cd "${ROOT}"/etc/vdr/plugins
+ local f
+ local moved=""
+ for f in epgsearch*.* .epgsearch*; do
+ [[ -e ${f} ]] || continue
+ mv "${f}" "${ROOT}/etc/vdr/plugins/epgsearch"
+ moved="${moved} ${f}"
+ done
+ elog "These files were moved:${moved}"
+ fi
+}