summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-extb/vdr-extb-0.3.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-extb/vdr-extb-0.3.1.ebuild')
-rw-r--r--media-plugins/vdr-extb/vdr-extb-0.3.1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/media-plugins/vdr-extb/vdr-extb-0.3.1.ebuild b/media-plugins/vdr-extb/vdr-extb-0.3.1.ebuild
new file mode 100644
index 000000000000..8338a703a281
--- /dev/null
+++ b/media-plugins/vdr-extb/vdr-extb-0.3.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: used to control the VDR Extension Board"
+HOMEPAGE="http://www.deltab.de/content/view/74/76/"
+SRC_URI="http://www.deltab.de/component/option,com_docman/task,doc_download/gid,102/ -> "${P}".tar.gz
+ mirror://vdrfiles/${PN}/extb_firmware_1.08_lircd.conf.zip
+ mirror://vdrfiles/${PN}/extb.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.6.0
+ app-misc/lirc"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ sed -i "${WORKDIR}"/extb/src/LinPIC/Makefile \
+ -e "s:\$(LDLIBS):\$(LDFLAGS) \$(LDLIBS):"
+
+ cd "${WORKDIR}"
+ epatch "${FILESDIR}/${P}-gentoo.diff"
+ epatch "${FILESDIR}/${P}_vdr-1.7.13.diff"
+}
+
+src_compile() {
+ vdr-plugin-2_src_compile
+
+ emake -C "${WORKDIR}/extb/src/LinPIC" all
+}
+src_install() {
+ vdr-plugin-2_src_install
+
+ dodoc README.de
+ dodoc "${WORKDIR}/lircd.conf.extb_FW1.08"
+ docinto wakeup
+ dodoc "${S}/wakeup/README.de"
+
+ dobin "${WORKDIR}/extb/src/LinPIC/picdl"
+ dobin "${WORKDIR}/extb/bin/extb.sh"
+ dobin "${WORKDIR}/extb/bin/status.sh"
+ dobin "${WORKDIR}/extb/bin/tx.sh"
+ dobin "${S}/wakeup/extb-poweroff.pl"
+ dobin "${S}/wakeup/examples/checkscript.sh"
+
+ insinto /usr/share/extb/
+ doins "${WORKDIR}/extb_1.08.hex"
+
+ insinto /etc/extb
+ doins "${WORKDIR}/extb/bin/PICflags.conf"
+ doins "${S}/wakeup/examples/extb-poweroff.conf"
+}
+
+pkg_postinst() {
+ vdr-plugin-2_pkg_postinst
+
+ einfo
+ einfo "You need to upload the included firmware (1.08)"
+ einfo "(you will find it in /usr/share/extb/)"
+ einfo "into the extension board and update your lircd.conf"
+ einfo "See the supplied lircd.conf.extb_FW1.08 in"
+ einfo "/usr/share/doc/vdrplugin-extb"
+}