summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2021-05-02 18:35:09 +0200
committerJoerg Bornkessel <hd_brummy@gentoo.org>2021-05-02 18:36:19 +0200
commit6c5374319debcf20472f938d7c3e55fa2d2ea742 (patch)
tree627fc87809faf5cebb09feeb230944d03fe9dadf /media-plugins/vdr-mplayer
parentdev-lang/python: Backport secfixes to 2.7.18_p9 (diff)
downloadgentoo-6c5374319debcf20472f938d7c3e55fa2d2ea742.tar.gz
gentoo-6c5374319debcf20472f938d7c3e55fa2d2ea742.tar.bz2
gentoo-6c5374319debcf20472f938d7c3e55fa2d2ea742.zip
media-plugins/vdr-mplayer: tc-directly call fixed
some minor clang warnings fixed Closes: https://bugs.gentoo.org/787557 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
Diffstat (limited to 'media-plugins/vdr-mplayer')
-rw-r--r--media-plugins/vdr-mplayer/files/vdr-mplayer-0.10.2_tc-directly.patch52
-rw-r--r--media-plugins/vdr-mplayer/vdr-mplayer-0.10.2-r1.ebuild (renamed from media-plugins/vdr-mplayer/vdr-mplayer-0.10.2.ebuild)3
2 files changed, 55 insertions, 0 deletions
diff --git a/media-plugins/vdr-mplayer/files/vdr-mplayer-0.10.2_tc-directly.patch b/media-plugins/vdr-mplayer/files/vdr-mplayer-0.10.2_tc-directly.patch
new file mode 100644
index 000000000000..67a97c7f6ac9
--- /dev/null
+++ b/media-plugins/vdr-mplayer/files/vdr-mplayer-0.10.2_tc-directly.patch
@@ -0,0 +1,52 @@
+https://bugs.gentoo.org/787557
+
+fixed call g++ directly fixed
+some minor clang warnings fixed
+
+Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org> (02 Mar 2021)
+diff -Naur mp3-0.10.2.orig/Makefile mp3-0.10.2/Makefile
+--- mp3-0.10.2.orig/Makefile 2021-05-02 16:13:39.489653108 +0200
++++ mp3-0.10.2/Makefile 2021-05-02 16:13:55.695653108 +0200
+@@ -179,7 +179,7 @@
+
+ # Dependencies:
+
+-MAKEDEP = g++ -MM -MG
++MAKEDEP = $(CXX) -MM -MG
+ DEPFILE = .dependencies
+ DEPFILES = $(subst i18n.c,,$(subst version.c,,$(OBJS:%.o=%.c) $(OBJS2:%.o=%.c)))
+ $(DEPFILE): Makefile $(DEPFILES) $(wildcard *.h)
+diff -Naur mp3-0.10.2.orig/data-mp3.c mp3-0.10.2/data-mp3.c
+--- mp3-0.10.2.orig/data-mp3.c 2021-05-02 16:13:39.490653108 +0200
++++ mp3-0.10.2/data-mp3.c 2021-05-02 16:14:18.543653108 +0200
+@@ -43,7 +43,7 @@
+ // image suffixes to search
+ const char *img_suff[] = { "jpg","png","gif",0 };
+ // exclude list for instant playlist creation
+-const char *excl_pl[] = { "*"PLAYLISTEXT,"*.jpg","*.gif","*.png",0 };
++const char *excl_pl[] = { "*" PLAYLISTEXT,"*.jpg","*.gif","*.png",0 };
+ // exclude list for song browser
+ const char *excl_br[] = { ".*","*.jpg","*.gif","*.png",0 };
+
+@@ -550,7 +550,7 @@
+
+ bool cPlayLists::Load(cFileSource *Source)
+ {
+- static const char *spec[] = { "*"PLAYLISTEXT,0 };
++ static const char *spec[] = { "*" PLAYLISTEXT,0 };
+ Clear();
+ bool res=ScanDir(Source,0,stFile,spec,0,false);
+ Sort();
+diff -Naur mp3-0.10.2.orig/data.c mp3-0.10.2/data.c
+--- mp3-0.10.2.orig/data.c 2021-05-02 16:13:39.490653108 +0200
++++ mp3-0.10.2/data.c 2021-05-02 16:14:27.279653108 +0200
+@@ -89,7 +89,8 @@
+ va_list ap;
+ va_start(ap,fmt);
+ char *str=0;
+- if(vasprintf(&str,fmt,ap)<0);
++ if(vasprintf(&str,fmt,ap)<0)
++ ;
+ va_end(ap);
+ return str;
+ }
diff --git a/media-plugins/vdr-mplayer/vdr-mplayer-0.10.2.ebuild b/media-plugins/vdr-mplayer/vdr-mplayer-0.10.2-r1.ebuild
index 306995560a53..9f8ce981fa05 100644
--- a/media-plugins/vdr-mplayer/vdr-mplayer-0.10.2.ebuild
+++ b/media-plugins/vdr-mplayer/vdr-mplayer-0.10.2-r1.ebuild
@@ -35,6 +35,9 @@ src_prepare() {
-i decoder.c \
-i player-mplayer.c
fi
+
+ # bug 787557
+ eapply "${FILESDIR}/${P}_tc-directly.patch"
}
src_install() {