summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-osdpip
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-osdpip')
-rw-r--r--media-plugins/vdr-osdpip/Manifest1
-rw-r--r--media-plugins/vdr-osdpip/files/vdr-osdpip-0.1.1-ffmpeg-1.patch26
-rw-r--r--media-plugins/vdr-osdpip/files/vdr-osdpip-libav-9.patch40
-rw-r--r--media-plugins/vdr-osdpip/metadata.xml12
-rw-r--r--media-plugins/vdr-osdpip/vdr-osdpip-0.1.2-r1.ebuild38
-rw-r--r--media-plugins/vdr-osdpip/vdr-osdpip-0.1.2.ebuild33
6 files changed, 150 insertions, 0 deletions
diff --git a/media-plugins/vdr-osdpip/Manifest b/media-plugins/vdr-osdpip/Manifest
new file mode 100644
index 000000000000..9f430db16cfa
--- /dev/null
+++ b/media-plugins/vdr-osdpip/Manifest
@@ -0,0 +1 @@
+DIST vdr-osdpip-0.1.2.tgz 50756 SHA256 08761f6474dd2e5bd4d3dc83b4d2d3b9169a04931cb8aca2e54fdb5ad979a0c6 SHA512 bc3345497e260d3249e1864a05181939b52a3fea115264af21d0efae10aa4406e9d4e5d348fce967a4fdb1adf2a3c7877b5b2d6840854f55f665800ac080a0eb WHIRLPOOL 0503bb4ed6b5838ee1ff7eca61507f79b14a9bf0824c69989cb73d4fa89b48dfb41197e8152d4798f775a288968679008bfbe9e851627447064fe8c1a6780aa2
diff --git a/media-plugins/vdr-osdpip/files/vdr-osdpip-0.1.1-ffmpeg-1.patch b/media-plugins/vdr-osdpip/files/vdr-osdpip-0.1.1-ffmpeg-1.patch
new file mode 100644
index 000000000000..b0304ad5adc0
--- /dev/null
+++ b/media-plugins/vdr-osdpip/files/vdr-osdpip-0.1.1-ffmpeg-1.patch
@@ -0,0 +1,26 @@
+Index: osdpip-0.1.1/decoder.h
+===================================================================
+--- osdpip-0.1.1.orig/decoder.h
++++ osdpip-0.1.1/decoder.h
+@@ -34,7 +34,7 @@ extern "C"
+ #include <libavcodec/avcodec.h>
+ #ifdef USE_SWSCALE
+ #include <libswscale/swscale.h>
+- #include <libavcodec/opt.h>
++ #include <libavutil/opt.h>
+ #endif
+ #else
+ #include <ffmpeg/avcodec.h>
+Index: osdpip-0.1.1/osdpip.c
+===================================================================
+--- osdpip-0.1.1.orig/osdpip.c
++++ osdpip-0.1.1/osdpip.c
+@@ -73,8 +73,6 @@ bool cPluginOsdpip::ProcessArgs(int argc
+
+ bool cPluginOsdpip::Initialize(void)
+ {
+- // must be called before using avcodec lib
+- avcodec_init();
+ // register all the codecs (you can also register only the codec
+ // you wish to have smaller code)
+ avcodec_register_all();
diff --git a/media-plugins/vdr-osdpip/files/vdr-osdpip-libav-9.patch b/media-plugins/vdr-osdpip/files/vdr-osdpip-libav-9.patch
new file mode 100644
index 000000000000..d1f531b325ce
--- /dev/null
+++ b/media-plugins/vdr-osdpip/files/vdr-osdpip-libav-9.patch
@@ -0,0 +1,40 @@
+diff -urN osdpip-0.1.2.old/decoder.c osdpip-0.1.2/decoder.c
+--- osdpip-0.1.2.old/decoder.c 2013-06-17 21:01:31.795476861 +0200
++++ osdpip-0.1.2/decoder.c 2013-06-17 21:01:57.153475959 +0200
+@@ -34,8 +34,8 @@
+ printf("codec not found\n");
+ return -1;
+ }
+- m_Context = avcodec_alloc_context();
+- if (avcodec_open(m_Context, m_Codec) < 0)
++ m_Context = avcodec_alloc_context3(m_Codec);
++ if (avcodec_open2(m_Context, m_Codec, NULL) < 0)
+ {
+ printf("could not open codec\n");
+ return -1;
+@@ -106,17 +106,17 @@
+ return -1;
+ }
+
+- av_set_int(context, "srcw", m_Context->width - (OsdPipSetup.CropLeft + OsdPipSetup.CropRight));
+- av_set_int(context, "srch", m_Context->height - (OsdPipSetup.CropTop + OsdPipSetup.CropBottom));
+- av_set_int(context, "src_format", PIX_FMT_YUV420P);
+- av_set_int(context, "dstw", m_Width);
+- av_set_int(context, "dsth", m_Height);
++ av_opt_set_int(context, "srcw", m_Context->width - (OsdPipSetup.CropLeft + OsdPipSetup.CropRight), 0);
++ av_opt_set_int(context, "srch", m_Context->height - (OsdPipSetup.CropTop + OsdPipSetup.CropBottom), 0);
++ av_opt_set_int(context, "src_format", PIX_FMT_YUV420P, 0);
++ av_opt_set_int(context, "dstw", m_Width, 0);
++ av_opt_set_int(context, "dsth", m_Height, 0);
+ #ifdef USE_NEW_FFMPEG_HEADERS
+- av_set_int(context, "dst_format", ConvertToRGB ? PIX_FMT_RGB32 : PIX_FMT_YUV420P);
++ av_opt_set_int(context, "dst_format", ConvertToRGB ? PIX_FMT_RGB32 : PIX_FMT_YUV420P, 0);
+ #else
+- av_set_int(context, "dst_format", ConvertToRGB ? PIX_FMT_RGBA32 : PIX_FMT_YUV420P);
++ av_opt_set_int(context, "dst_format", ConvertToRGB ? PIX_FMT_RGBA32 : PIX_FMT_YUV420P, 0);
+ #endif
+- av_set_int(context, "sws_flags", SWS_LANCZOS);
++ av_opt_set_int(context, "sws_flags", SWS_LANCZOS, 0);
+
+ if (sws_init_context(context, NULL, NULL) < 0) {
+ printf("Error initializing conversion context.\n");
diff --git a/media-plugins/vdr-osdpip/metadata.xml b/media-plugins/vdr-osdpip/metadata.xml
new file mode 100644
index 000000000000..d1b88e6872a7
--- /dev/null
+++ b/media-plugins/vdr-osdpip/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>vdr@gentoo.org</email>
+<name>Gentoo VDR Project</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-osdpip/vdr-osdpip-0.1.2-r1.ebuild b/media-plugins/vdr-osdpip/vdr-osdpip-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..116565863e4a
--- /dev/null
+++ b/media-plugins/vdr-osdpip/vdr-osdpip-0.1.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+VERSION="961" # every bump, new version
+
+inherit vdr-plugin-2 flag-o-matic
+
+DESCRIPTION="VDR plugin: Show another channel in the OSD"
+HOMEPAGE="http://projects.vdr-developer.org/projects/plg-osdpip"
+SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tgz"
+
+KEYWORDS="amd64 x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.7.27
+ >=media-libs/libmpeg2-0.5.1
+ >=virtual/ffmpeg-0.6.90"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ # UINT64_C is needed by ffmpeg headers
+ append-cxxflags -D__STDC_CONSTANT_MACROS
+
+ epatch "${FILESDIR}/${PN}-0.1.1-ffmpeg-1.patch"
+ epatch "${FILESDIR}/${PN}-libav-9.patch"
+
+ # tested with libav10/11, ffmpeg-2.5.4
+ sed -e "s:CODEC_ID_MPEG2VIDEO:AV_CODEC_ID_MPEG2VIDEO:"\
+ -e "s:avcodec_alloc_frame:av_frame_alloc:"\
+ -i decoder.c
+}
diff --git a/media-plugins/vdr-osdpip/vdr-osdpip-0.1.2.ebuild b/media-plugins/vdr-osdpip/vdr-osdpip-0.1.2.ebuild
new file mode 100644
index 000000000000..a88e26c504f2
--- /dev/null
+++ b/media-plugins/vdr-osdpip/vdr-osdpip-0.1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+VERSION="961" # every bump, new version
+
+inherit vdr-plugin-2 flag-o-matic
+
+DESCRIPTION="VDR plugin: Show another channel in the OSD"
+HOMEPAGE="http://projects.vdr-developer.org/projects/plg-osdpip"
+SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tgz"
+
+KEYWORDS="amd64 x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.7.27
+ >=media-libs/libmpeg2-0.5.1
+ >=virtual/ffmpeg-0.6.90"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ # UINT64_C is needed by ffmpeg headers
+ append-cxxflags -D__STDC_CONSTANT_MACROS
+
+ epatch "${FILESDIR}/${PN}-0.1.1-ffmpeg-1.patch"
+ epatch "${FILESDIR}/${PN}-libav-9.patch"
+}