summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-pilotskin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-pilotskin')
-rw-r--r--media-plugins/vdr-pilotskin/Manifest1
-rw-r--r--media-plugins/vdr-pilotskin/files/vdr-pilotskin-0.0.2-vdr-1.5.diff13
-rw-r--r--media-plugins/vdr-pilotskin/metadata.xml12
-rw-r--r--media-plugins/vdr-pilotskin/vdr-pilotskin-0.0.2-r1.ebuild27
4 files changed, 53 insertions, 0 deletions
diff --git a/media-plugins/vdr-pilotskin/Manifest b/media-plugins/vdr-pilotskin/Manifest
new file mode 100644
index 000000000000..193c4bc1cbf5
--- /dev/null
+++ b/media-plugins/vdr-pilotskin/Manifest
@@ -0,0 +1 @@
+DIST vdr-pilotskin-0.0.2.tgz 15871 SHA256 1f12bc9f40c0c4b6317a3dcf8a9d13f9ad162fb9d41344cb173c31a8a39a02f2 SHA512 2a15525900147a541968df6f49a206ee410c0e3e5079adcb2ebbc932f96a1539c62b1fa110d211a6b7215c1312ccfcf0b0a4c1a998c2f3fd65c0b9735d02cf87 WHIRLPOOL de3c6aa15b606f9f9ab59099ef18cc6dec362a57558d6b0442aa74d6818638df6cc1aa2ef2c67332a1a9c10813238be16245d4904ec14ef7aee975948459964e
diff --git a/media-plugins/vdr-pilotskin/files/vdr-pilotskin-0.0.2-vdr-1.5.diff b/media-plugins/vdr-pilotskin/files/vdr-pilotskin-0.0.2-vdr-1.5.diff
new file mode 100644
index 000000000000..d782363f5f4b
--- /dev/null
+++ b/media-plugins/vdr-pilotskin/files/vdr-pilotskin-0.0.2-vdr-1.5.diff
@@ -0,0 +1,13 @@
+Index: pilotskin-0.0.2/pilotskinosd.h
+===================================================================
+--- pilotskin-0.0.2.orig/pilotskinosd.h
++++ pilotskin-0.0.2/pilotskinosd.h
+@@ -12,8 +12,6 @@
+ #include "config.h"
+
+
+-static const cFont *font = cFont::GetFont(fontOsd);
+-static const int LINEHEIGHT = font->Height();
+ #define NBLINES 4
+
+ class cPilotskinOsd : public cOsdObject {
diff --git a/media-plugins/vdr-pilotskin/metadata.xml b/media-plugins/vdr-pilotskin/metadata.xml
new file mode 100644
index 000000000000..d1b88e6872a7
--- /dev/null
+++ b/media-plugins/vdr-pilotskin/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>vdr@gentoo.org</email>
+<name>Gentoo VDR Project</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-pilotskin/vdr-pilotskin-0.0.2-r1.ebuild b/media-plugins/vdr-pilotskin/vdr-pilotskin-0.0.2-r1.ebuild
new file mode 100644
index 000000000000..a1fd5a29dc2e
--- /dev/null
+++ b/media-plugins/vdr-pilotskin/vdr-pilotskin-0.0.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR plugin: fork of vdr-pilot - navigate through channels with skinnable design"
+HOMEPAGE="http://vdrwiki.free.fr/vdr/pilotskin/"
+SRC_URI="http://vdrwiki.free.fr/vdr/pilotskin/files/${P}.tgz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.3.36"
+
+PATCHES=("${FILESDIR}/${P}-vdr-1.5.diff")
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ sed -i pilotskin.c -e "s:RegisterI18n://RegisterI18n:"
+ remove_i18n_include pilotskin.c
+}