summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-recsearch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-recsearch')
-rw-r--r--media-plugins/vdr-recsearch/Manifest1
-rw-r--r--media-plugins/vdr-recsearch/metadata.xml12
-rw-r--r--media-plugins/vdr-recsearch/vdr-recsearch-0.3.5.ebuild31
3 files changed, 44 insertions, 0 deletions
diff --git a/media-plugins/vdr-recsearch/Manifest b/media-plugins/vdr-recsearch/Manifest
new file mode 100644
index 000000000000..89ea57a640ee
--- /dev/null
+++ b/media-plugins/vdr-recsearch/Manifest
@@ -0,0 +1 @@
+DIST vdr-recsearch-0.3.5.tar.gz 23920 SHA256 61324315baebcb0b3bc141751c1cbe36f93ab989dbdfabbd9110624fc61ab2b1 SHA512 97cac7ffd231b732ae91b2e86c74bf307c5901b718d23bbb9f2fec4da25cd80e23a41c9e35a88caf8c9bd190c07662fa64057b20fd760bbed9c2b94687f730b6 WHIRLPOOL 8ef728f68fe4522983d77ca8f2da3ff95bf90cd4c7c0bee7eb290cc4fedf2eec55b9bc2656a3a0052dbb0821a0d854211974f671a67c79e997c16871b32de296
diff --git a/media-plugins/vdr-recsearch/metadata.xml b/media-plugins/vdr-recsearch/metadata.xml
new file mode 100644
index 000000000000..da5ebae71107
--- /dev/null
+++ b/media-plugins/vdr-recsearch/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-tv</herd>
+ <maintainer>
+ <email>vdr@gentoo.org</email>
+ <name>Gentoo VDR Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">flensrocker/vdr-plugin-recsearch</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-plugins/vdr-recsearch/vdr-recsearch-0.3.5.ebuild b/media-plugins/vdr-recsearch/vdr-recsearch-0.3.5.ebuild
new file mode 100644
index 000000000000..1f6f88ae018c
--- /dev/null
+++ b/media-plugins/vdr-recsearch/vdr-recsearch-0.3.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: Search through your recordings and find the one you are looking for..."
+HOMEPAGE="https://github.com/flensrocker/vdr-plugin-recsearch"
+SRC_URI="https://github.com/flensrocker/vdr-plugin-recsearch/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-video/vdr-2.0.4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/vdr-plugin-recsearch-${PV}"
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ touch last.conf
+ touch searches.conf
+ insopts -m0644 -ovdr -gvdr
+ insinto /etc/vdr/plugins/${VDRPLUGIN}
+ doins last.conf searches.conf
+}