summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2015-09-27 13:25:42 +0200
committerJoerg Bornkessel <hd_brummy@gentoo.org>2015-09-27 13:25:42 +0200
commit77bea93197363f04587b605122b9b4a7fc2ce3e0 (patch)
tree9eee6d2458fcb81d3573004ab0c6fe4f3f4c8b50 /media-plugins/vdr-satip/vdr-satip-2.2.3.ebuild
parentcleanup; stable amd64 x86; bump (diff)
downloadgentoo-77bea93197363f04587b605122b9b4a7fc2ce3e0.tar.gz
gentoo-77bea93197363f04587b605122b9b4a7fc2ce3e0.tar.bz2
gentoo-77bea93197363f04587b605122b9b4a7fc2ce3e0.zip
bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'media-plugins/vdr-satip/vdr-satip-2.2.3.ebuild')
-rw-r--r--media-plugins/vdr-satip/vdr-satip-2.2.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-plugins/vdr-satip/vdr-satip-2.2.3.ebuild b/media-plugins/vdr-satip/vdr-satip-2.2.3.ebuild
new file mode 100644
index 000000000000..8f634997fe28
--- /dev/null
+++ b/media-plugins/vdr-satip/vdr-satip-2.2.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: integrates SAT>IP network devices seamlessly into VDR"
+HOMEPAGE="http://www.saunalahti.fi/~rahrenbe/vdr/satip/"
+SRC_URI="http://www.saunalahti.fi/~rahrenbe/vdr/satip/files/${P}.tgz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-video/vdr-2.2.0
+ >=net-misc/curl-7.36
+ || ( dev-libs/tinyxml
+ dev-libs/pugixml )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ if has_version "dev-libs/tinyxml" ; then
+ sed -e "s:#SATIP_USE_TINYXML:SATIP_USE_TINYXML:" -i Makefile
+ #BUILD_PARAMS+=" SATIP_USE_TINYXML = 1 "
+ fi
+}