summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-streamdev
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-streamdev')
-rw-r--r--media-plugins/vdr-streamdev/Manifest1
-rw-r--r--media-plugins/vdr-streamdev/files/confd-0.6.034
-rw-r--r--media-plugins/vdr-streamdev/files/rc-addon-0.6.0.sh26
-rw-r--r--media-plugins/vdr-streamdev/metadata.xml20
-rw-r--r--media-plugins/vdr-streamdev/vdr-streamdev-0.6.1.ebuild97
5 files changed, 178 insertions, 0 deletions
diff --git a/media-plugins/vdr-streamdev/Manifest b/media-plugins/vdr-streamdev/Manifest
new file mode 100644
index 000000000000..5ec1b4a3f4f4
--- /dev/null
+++ b/media-plugins/vdr-streamdev/Manifest
@@ -0,0 +1 @@
+DIST vdr-streamdev-0.6.1.tgz 186546 SHA256 b3ea814a572eb17699df4ae2a90a1ad6c22c0a68a8235e7f7ccf299d1ed43955 SHA512 bbe6231bd8e69e299c8d94173e7ed4b1f49e5b17b7bcadf2d1e827b5e8dd57c6b975c8c409fd44f252110099b3565a7d4d8c2f7d03636fc2d2e3580d0050d971 WHIRLPOOL e226ddbec680bb43857f96ae1553b71d218f87593cf179c65919444c19aa26392e42ef9dbe8607ddffc81ce781cb5a8b60123650a14be7c0997bc605b066c9f7
diff --git a/media-plugins/vdr-streamdev/files/confd-0.6.0 b/media-plugins/vdr-streamdev/files/confd-0.6.0
new file mode 100644
index 000000000000..1cb42eff3836
--- /dev/null
+++ b/media-plugins/vdr-streamdev/files/confd-0.6.0
@@ -0,0 +1,34 @@
+# /etc/conf.d/vdr.streamdev-server
+
+# Use your own remux script
+#
+# default: streamdevserver remux script is used
+# take a look at the README for handling
+#
+# allowed values: full path to your replacement script
+#
+#STREAMDEV_REMUX_SCRIPT="/full/path/to/your/own/remux-script"
+
+# You can configure optional authentication credentials
+# for the http protocol here
+#
+# ATTENTION: the colon character ":" is not allowed in
+# both the login and password !
+#
+# enable http_auth
+# allowed values: yes | no
+# default: no
+#
+#STREAMDEV_HTTP_AUTH_ENABLE="yes"
+
+# Set the user for http_auth
+# allowed values: your_user
+# default:
+#
+STREAMDEV_HTTP_LOGIN=""
+
+# Set the password for http_auth
+# allowed values: your_password
+# default:
+#
+STREAMDEV_HTTP_PASSWORD=""
diff --git a/media-plugins/vdr-streamdev/files/rc-addon-0.6.0.sh b/media-plugins/vdr-streamdev/files/rc-addon-0.6.0.sh
new file mode 100644
index 000000000000..35b961aa9871
--- /dev/null
+++ b/media-plugins/vdr-streamdev/files/rc-addon-0.6.0.sh
@@ -0,0 +1,26 @@
+# $Id$
+#
+# rc-addon-script for plugin streamdev-server
+#
+# Joerg Bornkessel <hd_brummy@g.o>
+
+plugin_pre_vdr_start() {
+
+ : ${STREAMDEV_REMUX_SCRIPT:=/usr/share/vdr/streamdev/externremux.sh}
+ add_plugin_param "-r ${STREAMDEV_REMUX_SCRIPT}"
+
+ if yesno ${STREAMDEV_HTTP_AUTH_ENABLE:-no}; then
+
+ if [[ -z ${STREAMDEV_HTTP_LOGIN} ]]; then
+ eerror "No user in /etc/conf.d/vdr.streamdev-server"
+ logger -t vdr "ERROR: need password for plugin vdr-streamdev-server"
+ fi
+
+ if [[ -z ${STREAMDEV_HTTP_PASSWORD} ]]; then
+ eerror "No password in /etc/conf.d/vdr.streamdev-server"
+ logger -t vdr "ERROR: need password for plugin vdr-streamdev-server"
+ fi
+
+ add_plugin_param "-a ${STREAMDEV_HTTP_LOGIN}:${STREAMDEV_HTTP_PASSWORD}"
+ fi
+}
diff --git a/media-plugins/vdr-streamdev/metadata.xml b/media-plugins/vdr-streamdev/metadata.xml
new file mode 100644
index 000000000000..afdf685c26ad
--- /dev/null
+++ b/media-plugins/vdr-streamdev/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-tv</herd>
+ <maintainer>
+ <email>vdr@gentoo.org</email>
+ <name>Gentoo VDR Project</name>
+ </maintainer>
+ <use>
+ <flag name="client">
+ Compile the VDR plugin vdr-streamdev-client
+ that acts like a dvb-budget card
+ </flag>
+ <flag name="server">
+ Compile the VDR plugin vdr-streamdev-server
+ that allows remote systems to access the
+ DVB cards used for the local VDR
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/media-plugins/vdr-streamdev/vdr-streamdev-0.6.1.ebuild b/media-plugins/vdr-streamdev/vdr-streamdev-0.6.1.ebuild
new file mode 100644
index 000000000000..ab17d2851054
--- /dev/null
+++ b/media-plugins/vdr-streamdev/vdr-streamdev-0.6.1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+VERSION="1580" # every bump, new version !
+
+DESCRIPTION="VDR Plugin: Client/Server and http streaming plugin"
+HOMEPAGE="http://projects.vdr-developer.org/projects/plg-streamdev"
+SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="client +server"
+
+DEPEND=">=media-video/vdr-1.7.25"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="|| ( client server )"
+
+# vdr-plugin-2.eclass changes
+PO_SUBDIR="client server"
+
+src_prepare() {
+ # make detection in vdr-plugin-2.eclass for new Makefile handling happy
+ echo "# SOFILE" >> Makefile
+
+ # rm unneeded entry
+ sed -i Makefile -e "s:-I\$(VDRDIR)/include::"
+
+ vdr-plugin-2_src_prepare
+
+ for flag in client server; do
+ if ! use ${flag}; then
+ sed -i Makefile \
+ -e '/^.PHONY:/s/'${flag}'//' \
+ -e '/^.PHONY:/s/'install-${flag}'//' \
+ -e '/^all:/s/'${flag}'//' \
+ -e '/^install:/s/'install-${flag}'//'
+ fi
+ done
+
+ fix_vdr_libsi_include server/livestreamer.c
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ if use server; then
+ insinto /usr/share/vdr/streamdev
+ doins streamdev-server/externremux.sh
+
+ insinto /usr/share/vdr/rcscript
+ newins "${FILESDIR}"/rc-addon-0.6.0.sh plugin-streamdev-server.sh
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}"/confd-0.6.0 vdr.streamdev-server
+
+ insinto /etc/vdr/plugins/streamdev-server
+ newins streamdev-server/streamdevhosts.conf streamdevhosts.conf
+ fowners vdr:vdr /etc/vdr -R
+ fi
+}
+
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.6.0"
+ previous_less_than_0_6_0=$?
+}
+
+pkg_postinst() {
+ vdr-plugin-2_pkg_postinst
+
+ if [[ -e "${ROOT}"/etc/vdr/plugins/streamdev/streamdevhosts.conf ]]; then
+ einfo "move config file to new config DIR ${ROOT}/etc/vdr/plugins/streamdev-server/"
+ mv "${ROOT}"/etc/vdr/plugins/streamdev/streamdevhosts.conf "${ROOT}"/etc/vdr/plugins/streamdev-server/streamdevhosts.conf
+ fi
+
+ if [[ $previous_less_than_0_6_0 = 0 ]]; then
+ einfo "The server-side setting \"Suspend behaviour\" has been dropped in 0.6.0 in favour"
+ einfo "of priority based precedence. A priority of 0 and above means that clients"
+ einfo "have precedence. A negative priority gives precedence to local live TV on the"
+ einfo "server. So if \"Suspend behaviour\" was previously set to \"Client may suspend\" or"
+ einfo "\"Never suspended\", you will have to configure a negative priority. If the"
+ einfo "\"Suspend behaviour\" was set to \"Always suspended\", the default values should do."
+ einfo ""
+ einfo "Configure the desired priorities for HTTP and IGMP Multicast streaming in the"
+ einfo "settings of streamdev-server. If you haven't updated all your streamdev-clients"
+ einfo "to at least 0.5.2, configure \"Legacy Client Priority\", too."
+ einfo ""
+ einfo "In streamdev-client, you should set \"Minimum Priority\" to -99. Adjust \"Live TV"
+ einfo "Priority\" if necessary."
+ fi
+}