summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2016-07-03 22:16:09 +0200
committerJoerg Bornkessel <hd_brummy@gentoo.org>2016-07-03 22:17:22 +0200
commit439cb2883c63842a8d8c111c704717cd23b7fd1f (patch)
treee8c1c4f8f457c2e6f75fc340b27a2d1469ce2c57 /media-plugins/vdr-suspendoutput/vdr-suspendoutput-2.0.1.ebuild
parentapp-office/libreoffice: Fix build with gcc-6, bug 584892 (diff)
downloadgentoo-439cb2883c63842a8d8c111c704717cd23b7fd1f.tar.gz
gentoo-439cb2883c63842a8d8c111c704717cd23b7fd1f.tar.bz2
gentoo-439cb2883c63842a8d8c111c704717cd23b7fd1f.zip
media-plugins/vdr-suspendoutput: bump, this fix wrt bug 574162; clean up old
Package-Manager: portage-2.3.0
Diffstat (limited to 'media-plugins/vdr-suspendoutput/vdr-suspendoutput-2.0.1.ebuild')
-rw-r--r--media-plugins/vdr-suspendoutput/vdr-suspendoutput-2.0.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-plugins/vdr-suspendoutput/vdr-suspendoutput-2.0.1.ebuild b/media-plugins/vdr-suspendoutput/vdr-suspendoutput-2.0.1.ebuild
new file mode 100644
index 000000000000..cfdbe7754af3
--- /dev/null
+++ b/media-plugins/vdr-suspendoutput/vdr-suspendoutput-2.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: Show still image instead of live tv to safe cpu"
+HOMEPAGE="http://phivdr.dyndns.org/vdr/vdr-suspendoutput/"
+SRC_URI="http://phivdr.dyndns.org/vdr/vdr-suspendoutput/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="media-video/vdr"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ # compile fix, wrt bug 574162
+ sed -e 246c"unsigned int TimeoutMs, bool runOnce)" \
+ -e 254c"unsigned int TimeoutMs, bool runOnce)" \
+ -i timer.h
+} \ No newline at end of file