summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-text2skin/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-text2skin/files')
-rw-r--r--media-plugins/vdr-text2skin/files/vdr-1.7.27.diff94
-rw-r--r--media-plugins/vdr-text2skin/files/vdr-text2skin-1.3.2-Makefile.patch71
-rw-r--r--media-plugins/vdr-text2skin/files/vdr-text2skin-1.3.2_vdr-2.1.2.diff15
3 files changed, 180 insertions, 0 deletions
diff --git a/media-plugins/vdr-text2skin/files/vdr-1.7.27.diff b/media-plugins/vdr-text2skin/files/vdr-1.7.27.diff
new file mode 100644
index 000000000000..9d3280cf5849
--- /dev/null
+++ b/media-plugins/vdr-text2skin/files/vdr-1.7.27.diff
@@ -0,0 +1,94 @@
+diff -Naur text2skin-1.3.2.orig/display.c text2skin-1.3.2/display.c
+--- text2skin-1.3.2.orig/display.c 2012-04-07 20:45:11.000000000 +0200
++++ text2skin-1.3.2/display.c 2012-04-07 20:45:47.000000000 +0200
+@@ -1233,17 +1233,17 @@
+
+ case tRecordingPriority:
+ return mRecording != NULL
+- ? (cxType)mRecording->priority
++ ? (cxType)mRecording->Priority()
+ : (cxType)false;
+
+ case tRecordingLifetime:
+ return mRecording != NULL
+- ? (cxType)mRecording->lifetime
++ ? (cxType)mRecording->Lifetime()
+ : (cxType)false;
+
+ case tRecordingDateTime:
+ return mRecording != NULL
+- ? (cxType)TimeType(mRecording->start, Token.Attrib.Text)
++ ? (cxType)TimeType(mRecording->Start(), Token.Attrib.Text)
+ : (cxType)false;
+
+ case tRecordingTitle:
+diff -Naur text2skin-1.3.2.orig/render.c text2skin-1.3.2/render.c
+--- text2skin-1.3.2.orig/render.c 2012-04-07 20:45:11.000000000 +0200
++++ text2skin-1.3.2/render.c 2012-04-07 20:48:29.000000000 +0200
+@@ -597,14 +597,14 @@
+ if (Marks) {
+ bool start = true;
+ for (const cMark *m = Marks->First(); m; m = Marks->Next(m)) {
+- txPoint pt(Pos.x + m->position * Size.w / Total, Pos.y);
++ txPoint pt(Pos.x + m->Position() * Size.w / Total, Pos.y);
+ if (Selected && start) {
+ const cMark *m2 = Marks->Next(m);
+ DrawRectangle(txPoint(pt.x, Pos.y + Size.h / 3),
+- txSize(((m2 ? m2->position : Total) - m->position)
++ txSize(((m2 ? m2->Position() : Total) - m->Position())
+ * Size.w / Total + 1, Size.h - Size.h * 2 / 3 + 1), Selected);
+ }
+- DrawMark(pt, Size, start, m->position == Current, false, Mark, Cur);
++ DrawMark(pt, Size, start, m->Position() == Current, false, Mark, Cur);
+ start = !start;
+ }
+ }
+@@ -614,15 +614,15 @@
+ if (Marks) {
+ bool start = true;
+ for (const cMark *m = Marks->First(); m; m = Marks->Next(m)) {
+- txPoint pt(Pos.x, Pos.y + m->position * Size.h / Total);
++ txPoint pt(Pos.x, Pos.y + m->Position() * Size.h / Total);
+ if (Selected && start) {
+ const cMark *m2 = Marks->Next(m);
+ DrawRectangle(txPoint(Pos.x + Size.w / 3, pt.y),
+ txSize(Size.w - Size.w * 2 / 3 + 1,
+- ((m2 ? m2->position : Total) - m->position)
++ ((m2 ? m2->Position() : Total) - m->Position())
+ * Size.h / Total + 1), Selected);
+ }
+- DrawMark(pt, Size, start, m->position == Current, true, Mark, Cur);
++ DrawMark(pt, Size, start, m->Position() == Current, true, Mark, Cur);
+ start = !start;
+ }
+ }
+diff -Naur text2skin-1.3.2.orig/common.c text2skin-1.3.2/common.c
+--- text2skin-1.3.2.orig/common.c 2012-04-07 20:54:59.000000000 +0200
++++ text2skin-1.3.2/common.c 2012-04-07 20:56:00.000000000 +0200
+@@ -255,11 +255,11 @@
+ int start = 1; // first frame
+ bool isStart = true;
+
+- for (cMark *m = marks.First(); m; m = marks.GetNext(m->position)) {
++ for (cMark *m = marks.First(); m; m = marks.GetNext(m->Position())) {
+ if (isStart)
+- start = m->position;
++ start = m->Position();
+ else
+- length += (double)(m->position - start + 1 + diffIFrame) / (60 * FramesPerSecond); // [min]
++ length += (double)(m->Position() - start + 1 + diffIFrame) / (60 * FramesPerSecond); // [min]
+
+ isStart = !isStart;
+ }
+diff -Naur text2skin-1.3.2.orig/status.c text2skin-1.3.2/status.c
+--- text2skin-1.3.2.orig/status.c 2012-04-07 20:59:39.000000000 +0200
++++ text2skin-1.3.2/status.c 2012-04-07 21:01:12.000000000 +0200
+@@ -314,7 +314,7 @@
+
+ case tReplayDateTime:
+ return mReplay != NULL
+- ? (cxType)TimeType(mReplay->start, Token.Attrib.Text)
++ ? (cxType)TimeType(mReplay->Start(), Token.Attrib.Text)
+ : (cxType)false;
+
+ case tReplayShortText:
diff --git a/media-plugins/vdr-text2skin/files/vdr-text2skin-1.3.2-Makefile.patch b/media-plugins/vdr-text2skin/files/vdr-text2skin-1.3.2-Makefile.patch
new file mode 100644
index 000000000000..cce51d79febc
--- /dev/null
+++ b/media-plugins/vdr-text2skin/files/vdr-text2skin-1.3.2-Makefile.patch
@@ -0,0 +1,71 @@
+diff --git a/Makefile b/Makefile
+index daa54d7..1163a8d 100644
+--- a/Makefile
++++ b/Makefile
+@@ -9,6 +9,7 @@ STRIP=strip
+ # External image lib to use: imagemagick, graphicsmagick, imlib2 or none
+ IMAGELIB = imagemagick
+
++#
+
+ # DO NOT EDIT BELOW THIS LINE UNLESS YOU KNOW WHAT YOU'RE DOING
+ # -------------------------------------------------------------
+@@ -29,13 +30,18 @@ VERSION = $(shell grep 'const char \*cText2SkinPlugin::VERSION *=' $(PLUGIN).c |
+ ### The C++ compiler and options:
+
+ CXX ?= g++
+-CXXFLAGS ?= -fPIC -Wall -Woverloaded-virtual
++ifdef DEBUG
++CXXFLAGS ?= -Wall -Woverloaded-virtual
++else
++CXXFLAGS ?= -Wall -Woverloaded-virtual -O3
++endif
++CXXFLAGS += -fPIC
+
+ ### The directory environment:
+
+-VDRDIR = ../../..
+-LIBDIR = ../../lib
+-TMPDIR = /tmp
++VDRDIR ?= ../../..
++LIBDIR ?= ../../lib
++TMPDIR ?= /tmp
+
+ ### Make sure that necessary options are included (VDR >= 1.7.13):
+
+@@ -88,8 +94,7 @@ endif
+ ifdef DEBUG
+ CXXFLAGS += -g -fno-inline
+ DEFINES += -DDEBUG
+-else
+- CXXFLAGS += -O3
++ STRIP=
+ ifdef BENCH
+ DEFINES += -DBENCH
+ endif
+@@ -118,7 +123,7 @@ $(DEPFILE): Makefile
+ -include $(DEPFILE)
+
+ ### Internationalization (I18N):
+-
++#
+ PODIR = po
+ LOCALEDIR = $(VDRDIR)/locale
+ I18Npo = $(notdir $(wildcard $(PODIR)/*.po))
+@@ -134,6 +139,7 @@ $(I18Npot): $(wildcard *.c)
+ $(LOCALEDIR)/%/LC_MESSAGES/vdr-$(PLUGIN).mo: $(PODIR)/%.po
+ @mkdir -p $(dir $@)
+ msgfmt -c -o $@ $<
++#
+
+ .PHONY: i18n
+ i18n: $(I18Npo:%.po=$(LOCALEDIR)/%/LC_MESSAGES/vdr-$(PLUGIN).mo)
+@@ -143,7 +149,7 @@ i18n: $(I18Npo:%.po=$(LOCALEDIR)/%/LC_MESSAGES/vdr-$(PLUGIN).mo)
+ libvdr-$(PLUGIN).so: $(OBJS)
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $(OBJS) $(LIBS) -o $@
+ @cp --remove-destination $@ $(LIBDIR)/$@.$(APIVERSION)
+-ifndef DEBUG
++ifdef STRIP
+ $(STRIP) $(LIBDIR)/$@.$(APIVERSION)
+ endif
+
diff --git a/media-plugins/vdr-text2skin/files/vdr-text2skin-1.3.2_vdr-2.1.2.diff b/media-plugins/vdr-text2skin/files/vdr-text2skin-1.3.2_vdr-2.1.2.diff
new file mode 100644
index 000000000000..7a4873db751d
--- /dev/null
+++ b/media-plugins/vdr-text2skin/files/vdr-text2skin-1.3.2_vdr-2.1.2.diff
@@ -0,0 +1,15 @@
+diff -Naur text2skin-1.3.2.orig/render.c text2skin-1.3.2/render.c
+--- text2skin-1.3.2.orig/render.c 2013-10-26 22:29:16.000000000 +0200
++++ text2skin-1.3.2/render.c 2013-10-26 22:33:19.000000000 +0200
+@@ -813,7 +813,11 @@
+ switch (Token.Type) {
+ case tFreeDiskSpace: {
+ int FreeMB;
++#if APIVERSNUM > 20101
++ cVideoDirectory::VideoDiskSpace(&FreeMB);
++#else
+ VideoDiskSpace(&FreeMB);
++#endif
+ Dprintf("FreeMB: %d, attrib type is %d\n", FreeMB,Token.Attrib.Type);
+ return Token.Attrib.Type == aString && Token.Attrib.Text.length() > 0
+ ? (cxType)DurationType(FreeMB * 60 / MB_PER_MINUTE,