summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-19 23:32:37 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-19 23:47:54 +0100
commit004d0ed46fdc06dea52671cf44ef5d4778a7b002 (patch)
treef8284694d94b9327b670a902f4317a8bb9415029 /media-plugins
parentmedia-sound/audacious: Re-add src_unpack for xmms skin, +qt5 default (diff)
downloadgentoo-004d0ed46fdc06dea52671cf44ef5d4778a7b002.tar.gz
gentoo-004d0ed46fdc06dea52671cf44ef5d4778a7b002.tar.bz2
gentoo-004d0ed46fdc06dea52671cf44ef5d4778a7b002.zip
media-plugins/audacious-plugins: Modernise src_configure
Use myeconfargs array. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/audacious-plugins/audacious-plugins-3.10.ebuild90
-rw-r--r--media-plugins/audacious-plugins/audacious-plugins-9999.ebuild88
2 files changed, 89 insertions, 89 deletions
diff --git a/media-plugins/audacious-plugins/audacious-plugins-3.10.ebuild b/media-plugins/audacious-plugins/audacious-plugins-3.10.ebuild
index 6cbc7f321652..01c53d0961d1 100644
--- a/media-plugins/audacious-plugins/audacious-plugins-3.10.ebuild
+++ b/media-plugins/audacious-plugins/audacious-plugins-3.10.ebuild
@@ -103,51 +103,51 @@ PATCHES=( "${FILESDIR}/${P}-fix-slow-search.patch" )
S="${WORKDIR}/${MY_P}"
src_configure() {
- if ! use mp3 ; then
- ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
- fi
+ use mp3 || ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
- econf \
- --enable-mpris2 \
- --enable-qt \
- --enable-songchange \
- --disable-aosd \
- --disable-coreaudio \
- --disable-gtk \
- --disable-hotkey \
- --disable-notify \
- --disable-oss4 \
- --disable-qtglspectrum \
- --disable-sndio \
- $(use_enable aac) \
- $(use_enable alsa) \
- $(use_enable ampache) \
- $(use_enable bs2b) \
- $(use_enable cdda cdaudio) \
- $(use_enable cue) \
- $(use_enable flac) \
- $(use_enable flac filewriter) \
- $(use_enable fluidsynth amidiplug) \
- $(use_enable gme console) \
- $(use_enable http neon) \
- $(use_enable jack) \
- $(use_enable lame filewriter_mp3) \
- $(use_enable libnotify notify) \
- $(use_enable libsamplerate resample) \
- $(use_enable lirc) \
- $(use_enable mms) \
- $(use_enable modplug) \
- $(use_enable mp3 mpg123) \
- $(use_enable nls) \
- $(use_enable pulseaudio pulse) \
- $(use_enable qtmedia qtaudio) \
- $(use_enable scrobbler scrobbler2) \
- $(use_enable sdl sdlout) \
- $(use_enable sid) \
- $(use_enable sndfile) \
- $(use_enable soxr) \
- $(use_enable speedpitch) \
- $(use_enable vorbis) \
- $(use_enable wavpack) \
+ local myeconfargs=(
+ --enable-mpris2
+ --enable-qt
+ --enable-songchange
+ --disable-aosd
+ --disable-coreaudio
+ --disable-gtk
+ --disable-hotkey
+ --disable-notify
+ --disable-oss4
+ --disable-qtglspectrum
+ --disable-sndio
+ $(use_enable aac)
+ $(use_enable alsa)
+ $(use_enable ampache)
+ $(use_enable bs2b)
+ $(use_enable cdda cdaudio)
+ $(use_enable cue)
+ $(use_enable flac)
+ $(use_enable flac filewriter)
+ $(use_enable fluidsynth amidiplug)
+ $(use_enable gme console)
+ $(use_enable http neon)
+ $(use_enable jack)
+ $(use_enable lame filewriter_mp3)
+ $(use_enable libnotify notify)
+ $(use_enable libsamplerate resample)
+ $(use_enable lirc)
+ $(use_enable mms)
+ $(use_enable modplug)
+ $(use_enable mp3 mpg123)
+ $(use_enable nls)
+ $(use_enable pulseaudio pulse)
+ $(use_enable qtmedia qtaudio)
+ $(use_enable scrobbler scrobbler2)
+ $(use_enable sdl sdlout)
+ $(use_enable sid)
+ $(use_enable sndfile)
+ $(use_enable soxr)
+ $(use_enable speedpitch)
+ $(use_enable vorbis)
+ $(use_enable wavpack)
$(use_with ffmpeg ffmpeg $(usex libav libav ffmpeg))
+ )
+ econf "${myeconfargs[@]}"
}
diff --git a/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild b/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild
index 944bc654f1d9..bcc581ce8a05 100644
--- a/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild
+++ b/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild
@@ -117,50 +117,50 @@ src_prepare() {
}
src_configure() {
- if ! use mp3 ; then
- ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
- fi
+ use mp3 || ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
- econf \
- --enable-mpris2 \
- --enable-songchange \
- --disable-oss4 \
- --disable-qtglspectrum \
- --disable-coreaudio \
- --disable-sndio \
- $(use_enable aac) \
- $(use_enable alsa) \
- $(use_enable ampache) \
- $(use_enable aosd) \
- $(use_enable bs2b) \
- $(use_enable cdda cdaudio) \
- $(use_enable cue) \
- $(use_enable flac) \
- $(use_enable flac filewriter) \
- $(use_enable fluidsynth amidiplug) \
- $(use_enable gme console) \
- $(use_enable gtk) \
- $(use_enable hotkeys hotkey) \
- $(use_enable http neon) \
- $(use_enable jack) \
- $(use_enable lame filewriter_mp3) \
- $(use_enable libnotify notify) \
- $(use_enable libsamplerate resample) \
- $(use_enable lirc) \
- $(use_enable mms) \
- $(use_enable modplug) \
- $(use_enable mp3 mpg123) \
- $(use_enable nls) \
- $(use_enable pulseaudio pulse) \
- $(use_enable qt5 qt) \
- $(use_enable qtmedia qtaudio) \
- $(use_enable scrobbler scrobbler2) \
- $(use_enable sdl sdlout) \
- $(use_enable sid) \
- $(use_enable sndfile) \
- $(use_enable soxr) \
- $(use_enable speedpitch) \
- $(use_enable vorbis) \
- $(use_enable wavpack) \
+ local myeconfargs=(
+ --enable-mpris2
+ --enable-songchange
+ --disable-oss4
+ --disable-qtglspectrum
+ --disable-coreaudio
+ --disable-sndio
+ $(use_enable aac)
+ $(use_enable alsa)
+ $(use_enable ampache)
+ $(use_enable aosd)
+ $(use_enable bs2b)
+ $(use_enable cdda cdaudio)
+ $(use_enable cue)
+ $(use_enable flac)
+ $(use_enable flac filewriter)
+ $(use_enable fluidsynth amidiplug)
+ $(use_enable gme console)
+ $(use_enable gtk)
+ $(use_enable hotkeys hotkey)
+ $(use_enable http neon)
+ $(use_enable jack)
+ $(use_enable lame filewriter_mp3)
+ $(use_enable libnotify notify)
+ $(use_enable libsamplerate resample)
+ $(use_enable lirc)
+ $(use_enable mms)
+ $(use_enable modplug)
+ $(use_enable mp3 mpg123)
+ $(use_enable nls)
+ $(use_enable pulseaudio pulse)
+ $(use_enable qt5 qt)
+ $(use_enable qtmedia qtaudio)
+ $(use_enable scrobbler scrobbler2)
+ $(use_enable sdl sdlout)
+ $(use_enable sid)
+ $(use_enable sndfile)
+ $(use_enable soxr)
+ $(use_enable speedpitch)
+ $(use_enable vorbis)
+ $(use_enable wavpack)
$(use_with ffmpeg ffmpeg $(usex libav libav ffmpeg))
+ )
+ econf "${myeconfargs[@]}"
}