summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-07-02 17:07:22 -0400
committerCraig Andrews <candrews@gentoo.org>2019-07-02 17:16:29 -0400
commit1903161ecf88f4f978c40880b88bc7c5761de51c (patch)
tree602edc14ba5f52ffa0f96adcf13fb5ccd855b3f2 /media-plugins
parentmedia-plugins/kodi-game-libretro-snes9x: 1.58.0.6 version bump (diff)
downloadgentoo-1903161ecf88f4f978c40880b88bc7c5761de51c.tar.gz
gentoo-1903161ecf88f4f978c40880b88bc7c5761de51c.tar.bz2
gentoo-1903161ecf88f4f978c40880b88bc7c5761de51c.zip
media-plugins/kodi-game-libretro-nestopia: 1.50.0.3 versiom bump
Bug: https://bugs.gentoo.org/688474 Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/kodi-game-libretro-nestopia/Manifest1
-rw-r--r--media-plugins/kodi-game-libretro-nestopia/kodi-game-libretro-nestopia-1.50.0.3.ebuild38
-rw-r--r--media-plugins/kodi-game-libretro-nestopia/kodi-game-libretro-nestopia-9999.ebuild7
3 files changed, 43 insertions, 3 deletions
diff --git a/media-plugins/kodi-game-libretro-nestopia/Manifest b/media-plugins/kodi-game-libretro-nestopia/Manifest
new file mode 100644
index 000000000000..00cff3df3ac9
--- /dev/null
+++ b/media-plugins/kodi-game-libretro-nestopia/Manifest
@@ -0,0 +1 @@
+DIST kodi-game-libretro-nestopia-1.50.0.3.tar.gz 793893 BLAKE2B 89015bb8c687685264e4a8c34cf1caad87cfa1a3611cbd67b540ddb31e9e75049eed328b51c69702e92e358a659d4e503ccdac1b52b7db70688e1236529536ad SHA512 4c41db8c77d24301f00b9d0283c948ae3c4176228e733a316fa5b2eba60ceea4dd094f48270d545008f144d3316cf5f8f190017f70e8378b9fbcbcdb2d8220e6
diff --git a/media-plugins/kodi-game-libretro-nestopia/kodi-game-libretro-nestopia-1.50.0.3.ebuild b/media-plugins/kodi-game-libretro-nestopia/kodi-game-libretro-nestopia-1.50.0.3.ebuild
new file mode 100644
index 000000000000..49c4284c2283
--- /dev/null
+++ b/media-plugins/kodi-game-libretro-nestopia/kodi-game-libretro-nestopia-1.50.0.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Nestopia GameClient for Kodi"
+HOMEPAGE="https://github.com/kodi-game/game.libretro.nestopia"
+SRC_URI=""
+
+if [[ ${PV} == *9999 ]]; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/kodi-game/game.libretro.nestopia.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ CODENAME="Leia"
+ SRC_URI="https://github.com/kodi-game/game.libretro.nestopia/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/game.libretro.nestopia-${PV}-${CODENAME}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-18*
+ games-emulation/libretro-nestopia
+ "
+RDEPEND="
+ media-plugins/kodi-game-libretro
+ ${DEPEND}
+ "
+src_prepare() {
+ echo 'find_library(NESTOPIA_LIB NAMES nestopia_libretro${CMAKE_SHARED_LIBRARY_SUFFIX} PATH_SUFFIXES libretro)' > "${S}/Findlibretro-nestopia.cmake" || die
+ default
+}
diff --git a/media-plugins/kodi-game-libretro-nestopia/kodi-game-libretro-nestopia-9999.ebuild b/media-plugins/kodi-game-libretro-nestopia/kodi-game-libretro-nestopia-9999.ebuild
index 532ff29f02e5..f57205d81698 100644
--- a/media-plugins/kodi-game-libretro-nestopia/kodi-game-libretro-nestopia-9999.ebuild
+++ b/media-plugins/kodi-game-libretro-nestopia/kodi-game-libretro-nestopia-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -15,8 +15,9 @@ if [[ ${PV} == *9999 ]]; then
inherit git-r3
else
KEYWORDS="~amd64 ~x86"
- SRC_URI="https://github.com/kodi-game/game.libretro.nestopia/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/game.libretro.nestopia-${PV}"
+ CODENAME="Leia"
+ SRC_URI="https://github.com/kodi-game/game.libretro.nestopia/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/game.libretro.nestopia-${PV}-${CODENAME}"
fi
LICENSE="GPL-2"