summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-11-06 10:33:18 -0500
committerCraig Andrews <candrews@gentoo.org>2018-11-06 10:58:07 -0500
commit19d1cc949af0aae05d3c26e3002573e94b093275 (patch)
tree6bfdd1971e48be4eb6e9199dcc989dfc7510344a /media-plugins
parentmedia-plugins/kodi-visualization-waveform: 2.0.1 version bump (diff)
downloadgentoo-19d1cc949af0aae05d3c26e3002573e94b093275.tar.gz
gentoo-19d1cc949af0aae05d3c26e3002573e94b093275.tar.bz2
gentoo-19d1cc949af0aae05d3c26e3002573e94b093275.zip
media-plugins/kodi-peripheral-joystick: 1.4.6 version bump
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/kodi-peripheral-joystick/Manifest1
-rw-r--r--media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.4.6.ebuild37
-rw-r--r--media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-9999.ebuild6
3 files changed, 41 insertions, 3 deletions
diff --git a/media-plugins/kodi-peripheral-joystick/Manifest b/media-plugins/kodi-peripheral-joystick/Manifest
index c2865d0da672..46d75d821fa6 100644
--- a/media-plugins/kodi-peripheral-joystick/Manifest
+++ b/media-plugins/kodi-peripheral-joystick/Manifest
@@ -1,2 +1,3 @@
DIST kodi-peripheral-joystick-1.3.2.tar.gz 82787 BLAKE2B c3edcc037161e7f1b865b1761a1296e15d6428ac6f32907569f8b32d3a7ecd7e2c27103ce72079b92b4329818d6709209d8f7caea386223fef6e59df281774fd SHA512 9aa2e5d1af51b83abc0691fb9f6c7603d07c37b61fde898e2010d6370b9dca44275bd53caa2252479128360bc97eb8bd904d268a9c0cab7f2958c0b31f64ba1f
DIST kodi-peripheral-joystick-1.3.3.tar.gz 84408 BLAKE2B 53ac931708319945c132c7a835fd37e4fcd2c003d64db32c7a888af116625746b96685563dd732873810f28adec20ff5dbed37bd66dcb6bff74cdd192f5a45bb SHA512 e566cfab838b471f4d5cd6d1bde48479868bf1e401e2d5512627f6cfad606c9ec359fade3612dc32424b4a5baffad82278d25906e59062bea9e8aea009754a78
+DIST kodi-peripheral-joystick-1.4.6.tar.gz 91142 BLAKE2B c80daf4e9a425c88ecb323d7f5ab7538aa5a8af06758723310f133f63ac65b74650f6374e4361e9086813474a6b84cf54bb8bc054d54eaec19c1ab32da5181e9 SHA512 ae42a295e548c6bda7a258d02d7a68ec3f34c66e88b1e3848181d8fb76da6ff83f19f8adc007e2697c096052fdd1ea9879b178aab9f8f4118f4d2d57691c2a7c
diff --git a/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.4.6.ebuild b/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.4.6.ebuild
new file mode 100644
index 000000000000..e2e2c669b701
--- /dev/null
+++ b/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.4.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Libretro compatibility layer for the Kodi Game API"
+HOMEPAGE="https://github.com/xbmc/peripheral.joystick"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/xbmc/peripheral.joystick.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/xbmc/peripheral.joystick/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/peripheral.joystick-${PV}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-18*
+ =media-libs/kodi-platform-18*
+ =dev-libs/libplatform-2*
+ dev-libs/libpcre
+ "
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-9999.ebuild b/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-9999.ebuild
index a5cfea8b92ed..614e3fb6c4cb 100644
--- a/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-9999.ebuild
+++ b/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -27,8 +27,8 @@ SLOT="0"
IUSE=""
DEPEND="
- =media-tv/kodi-9999
- =media-libs/kodi-platform-9999
+ ~media-tv/kodi-9999
+ ~media-libs/kodi-platform-9999
=dev-libs/libplatform-2*
dev-libs/libpcre
"