summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2016-09-28 11:27:10 +0200
committerJoerg Bornkessel <hd_brummy@gentoo.org>2016-09-28 11:27:10 +0200
commit3501505d34d47dc7e7d2bacbb8d266d88aa6ee51 (patch)
tree29ccbc4dc8b180bad4b7100c03d511a7fc8e5627 /media-plugins
parentsys-kernel/hardened-sources: version bump to 4.7.5 (diff)
downloadgentoo-3501505d34d47dc7e7d2bacbb8d266d88aa6ee51.tar.gz
gentoo-3501505d34d47dc7e7d2bacbb8d266d88aa6ee51.tar.bz2
gentoo-3501505d34d47dc7e7d2bacbb8d266d88aa6ee51.zip
media-plugins/vdr-iptv: fix c11++ compile
Package-Manager: portage-2.3.0
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-iptv/files/vdr-iptv-2.2.1_c++11.patch28
-rw-r--r--media-plugins/vdr-iptv/vdr-iptv-2.2.1-r1.ebuild43
2 files changed, 71 insertions, 0 deletions
diff --git a/media-plugins/vdr-iptv/files/vdr-iptv-2.2.1_c++11.patch b/media-plugins/vdr-iptv/files/vdr-iptv-2.2.1_c++11.patch
new file mode 100644
index 000000000000..c188291ed86a
--- /dev/null
+++ b/media-plugins/vdr-iptv/files/vdr-iptv-2.2.1_c++11.patch
@@ -0,0 +1,28 @@
+common.h still use function typeof,
+this was never defined in c++ and is
+not supported in c++11 anymore
+so we revert back to gnu++03 as it is not fixed by upstream
+Signed-of-by: Joerg Bornkessel <hd_brummy@gentoo.org> (2016/aug/01)
+diff -Naur satip-2.2.3.orig/Makefile satip-2.2.3/Makefile
+--- satip-2.2.3.orig/Makefile 2016-08-03 23:17:36.769080128 +0200
++++ satip-2.2.3/Makefile 2016-08-03 23:18:36.399080128 +0200
+@@ -32,6 +32,7 @@
+
+ export CFLAGS = $(call PKGCFG,cflags)
+ export CXXFLAGS = $(call PKGCFG,cxxflags)
++export CXXFLAGS += -std=gnu++03
+ STRIP = true
+
+ ### The version number of VDR's plugin API:
+diff -Naur iptv-2.2.1.orig/common.h iptv-2.2.1/common.h
+--- iptv-2.2.1.orig/common.h 2016-08-07 19:32:59.623090044 +0200
++++ iptv-2.2.1/common.h 2016-08-07 19:33:30.243091614 +0200
+@@ -36,7 +36,7 @@
+ do { \
+ if (exp) { \
+ char tmp[64]; \
+- esyslog("[%s,%d]: "errstr": %s", __FILE__, __LINE__, \
++ esyslog("[%s,%d]: " errstr ": %s", __FILE__, __LINE__, \
+ strerror_r(errno, tmp, sizeof(tmp))); \
+ func; \
+ ret; \
diff --git a/media-plugins/vdr-iptv/vdr-iptv-2.2.1-r1.ebuild b/media-plugins/vdr-iptv/vdr-iptv-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..9abd462370bd
--- /dev/null
+++ b/media-plugins/vdr-iptv/vdr-iptv-2.2.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR plugin: Add a logical device capable of receiving IPTV"
+HOMEPAGE="http://www.saunalahti.fi/~rahrenbe/vdr/iptv/"
+SRC_URI="http://www.saunalahti.fi/~rahrenbe/vdr/iptv/files/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-2.1.6"
+RDEPEND="${DEPEND}
+ net-misc/curl"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ fix_vdr_libsi_include sidscanner.c
+
+ eapply "${FILESDIR}/${P}_c++11.patch"
+}
+
+#src_install() {
+# vdr-plugin-2_src_install
+
+# dobin iptv/image.sh
+# dobin iptv/iptvstream-notrap.sh
+# dobin iptv/linein.sh
+# dobin iptv/webcam.sh
+# dobin iptv/internetradio.sh
+# dobin iptv/iptvstream.sh
+# dobin iptv/vlc2iptv
+
+# insinto /usr/share/vdr/plugins/iptv
+# doins iptv/*
+#}