summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-03-28 16:18:52 -0400
committerCraig Andrews <candrews@gentoo.org>2021-03-28 16:19:26 -0400
commit4c4dccd3fe5e0b385591f45732fb1182a22606f6 (patch)
tree62b0b0c80b6b32b12d61bda36b488f6336e1c5d9 /media-plugins
parentwww-client/dillo: keyword 3.0.5-r3 for arm64 (diff)
downloadgentoo-4c4dccd3fe5e0b385591f45732fb1182a22606f6.tar.gz
gentoo-4c4dccd3fe5e0b385591f45732fb1182a22606f6.tar.bz2
gentoo-4c4dccd3fe5e0b385591f45732fb1182a22606f6.zip
media-plugins/kodi-inputstream-adaptive: 2.6.8 version bump
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/kodi-inputstream-adaptive/Manifest1
-rw-r--r--media-plugins/kodi-inputstream-adaptive/kodi-inputstream-adaptive-2.6.8.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/media-plugins/kodi-inputstream-adaptive/Manifest b/media-plugins/kodi-inputstream-adaptive/Manifest
index 72a79d2134b1..8acb5e9c78f6 100644
--- a/media-plugins/kodi-inputstream-adaptive/Manifest
+++ b/media-plugins/kodi-inputstream-adaptive/Manifest
@@ -1 +1,2 @@
DIST kodi-inputstream-adaptive-2.6.7.tar.gz 748459 BLAKE2B 389525128fb8178d6de2e58d72225bf5a96cbe4f446e190e930aa42afa804c659b35cef281cb8e55c87891f1949087571dac45af218bdb7092680535ff804586 SHA512 60c1f051d50fef21697e6f1e1570bebbaaf3b8f5d4fd207bfdfbd553f1eafb26305af1138c224b2ddfb4ea9c88931991cf46fcbde39b35992ea93884705760c8
+DIST kodi-inputstream-adaptive-2.6.8.tar.gz 748575 BLAKE2B 0077d693efa7a468d4e7fcac2610114a383771f1a8741d8fee4bf788304b0147ed05d5cd03de17e64c8510d1db9b2e751d4bfb7f84df3a3decfaf01963b557dd SHA512 22299cc6dbb6cd56f8fa2f96758907c0dfc6d2d635436b12ad6afc2928e3ca2d5b6beea1f1d72e0ccf90eafeaec983f77ac0e474f0b176677fd3e5b97f2560df
diff --git a/media-plugins/kodi-inputstream-adaptive/kodi-inputstream-adaptive-2.6.8.ebuild b/media-plugins/kodi-inputstream-adaptive/kodi-inputstream-adaptive-2.6.8.ebuild
new file mode 100644
index 000000000000..48e18f09b005
--- /dev/null
+++ b/media-plugins/kodi-inputstream-adaptive/kodi-inputstream-adaptive-2.6.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake kodi-addon
+
+DESCRIPTION="Kodi's Adaptive inputstream addon"
+HOMEPAGE="https://github.com/peak3d/inputstream.adaptive.git"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/peak3d/inputstream.adaptive.git"
+ EGIT_BRANCH="Matrix"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ CODENAME="Matrix"
+ SRC_URI="https://github.com/peak3d/inputstream.adaptive/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/inputstream.adaptive-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-libs/expat
+ =media-tv/kodi-19*
+ "
+RDEPEND="
+ ${DEPEND}
+ "
+
+src_prepare() {
+ [ -d depends ] && rm -rf depends || die
+ cmake_src_prepare
+}