summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 06:13:19 +0100
committerSam James <sam@gentoo.org>2021-04-13 00:26:18 +0000
commit4f8ff43425ecd07a282e1e2be83454c95e62cd6f (patch)
treeff885a1c0c896b14011ed41b073347f8c74df1db /media-plugins
parentmedia-plugins/live: call pkg-config via toolchain-funcs.eclass helper (diff)
downloadgentoo-4f8ff43425ecd07a282e1e2be83454c95e62cd6f.tar.gz
gentoo-4f8ff43425ecd07a282e1e2be83454c95e62cd6f.tar.bz2
gentoo-4f8ff43425ecd07a282e1e2be83454c95e62cd6f.zip
media-plugins/vdr-xineliboutput: call pkg-config via toolchain-funcs.eclass helper
This ensures we call the correct pkg-config in e.g. cross. Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0-r2.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0-r2.ebuild b/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0-r2.ebuild
index 67a25eda7352..c3df9aff749c 100644
--- a/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0-r2.ebuild
+++ b/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -61,7 +61,7 @@ pkg_setup() {
vdr-plugin-2_pkg_setup
if use xine; then
- XINE_PLUGIN_DIR=$(pkg-config --variable=plugindir libxine)
+ XINE_PLUGIN_DIR=$($(tc-getPKG_CONFIG) --variable=plugindir libxine)
[ -z "${XINE_PLUGIN_DIR}" ] && die "Could not find xine plugin dir"
fi
}