summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2021-03-21 17:53:17 +0100
committerJoerg Bornkessel <hd_brummy@gentoo.org>2021-03-21 17:53:57 +0100
commit8639f1eb81e069ae5a11fb136427a42848fcd083 (patch)
tree31536148e1f318b6d041a7e401461c52cbedbfed /media-plugins
parentmedia-plugins/vdr-rssreader: version bump (diff)
downloadgentoo-8639f1eb81e069ae5a11fb136427a42848fcd083.tar.gz
gentoo-8639f1eb81e069ae5a11fb136427a42848fcd083.tar.bz2
gentoo-8639f1eb81e069ae5a11fb136427a42848fcd083.zip
media-plugins/vdr-fritzbox: calls ar directly fixed
Closes: https://bugs.gentoo.org/740290 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-fritzbox/vdr-fritzbox-1.5.3-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-plugins/vdr-fritzbox/vdr-fritzbox-1.5.3-r2.ebuild b/media-plugins/vdr-fritzbox/vdr-fritzbox-1.5.3-r2.ebuild
new file mode 100644
index 000000000000..860f542aaea9
--- /dev/null
+++ b/media-plugins/vdr-fritzbox/vdr-fritzbox-1.5.3-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: Inform about incoming phone-calls and use the fritz!box phonebook"
+HOMEPAGE="https://github.com/jowi24/vdr-fritz"
+SRC_URI="https://github.com/jowi24/vdr-fritz/releases/download/${PV}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libgcrypt:0
+ dev-libs/boost[threads]
+ media-video/vdr"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-boost-1.67.patch" )
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ # do not call ar directly
+ export _VDRAR="$(tc-getAR)"
+ sed -e "s:\@ar :\@\$(_VDRAR) :" \
+ -i libconv++/Makefile \
+ -i libfritz++/Makefile \
+ -i liblog++/Makefile \
+ -i libnet++/Makefile || die
+}
+
+pkg_postinst() {
+ elog "It is recommend to update your firmware release to the latest."
+ elog
+ elog "The integrated call monitor (available in Fritz!Box official"
+ elog "firmware releases >= *.04.29) has to be enabled in order to"
+ elog "have the vdr-fritzbox plugin display anything on your tv. To"
+ elog "enable it call #96*5* from your telephone. If that doesn't"
+ elog "work for you, read the documentation for further instructions."
+}