summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-11-17 22:14:08 -0500
committerCraig Andrews <candrews@gentoo.org>2018-11-17 22:14:08 -0500
commit98ff05c7506ebb76de02a842ecc002a8daf3e080 (patch)
treeee0d492d2b2c625f60d6a38dff0651c3fbd2e3ad /media-plugins
parentmedia-plugins/kodi-audiodecoder-nosefart: 1.1.0 is for Kodi 17 only (diff)
downloadgentoo-98ff05c7506ebb76de02a842ecc002a8daf3e080.tar.gz
gentoo-98ff05c7506ebb76de02a842ecc002a8daf3e080.tar.bz2
gentoo-98ff05c7506ebb76de02a842ecc002a8daf3e080.zip
media-plugins/kodi-audiodecoder-nosefart: 2.0.0 version bump
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/kodi-audiodecoder-nosefart/Manifest1
-rw-r--r--media-plugins/kodi-audiodecoder-nosefart/kodi-audiodecoder-nosefart-2.0.0.ebuild36
-rw-r--r--media-plugins/kodi-audiodecoder-nosefart/kodi-audiodecoder-nosefart-9999.ebuild11
3 files changed, 43 insertions, 5 deletions
diff --git a/media-plugins/kodi-audiodecoder-nosefart/Manifest b/media-plugins/kodi-audiodecoder-nosefart/Manifest
index 619eef7fb1bc..4699be6396af 100644
--- a/media-plugins/kodi-audiodecoder-nosefart/Manifest
+++ b/media-plugins/kodi-audiodecoder-nosefart/Manifest
@@ -1 +1,2 @@
DIST kodi-audiodecoder-nosefart-1.1.0.tar.gz 59921 BLAKE2B 617b001325a43e25ab6541534a33b7e43d4f67d754bb741e0172705b27413bdc98a93afbcf3e00bae25f1d4709f589a9588d70109a1c4c2cb89b4d8be9dce2d1 SHA512 c85768e3b7b31607429d85f6d2f9254bb42a4500a0e42b0a76d953a87b6d2275cef4ed922eb7a2af51770b90cb35403171df6258dae9157683be0a07304f6e6b
+DIST kodi-audiodecoder-nosefart-2.0.0.tar.gz 61006 BLAKE2B 8c3499b8820eb124f6532f722fae39c10880b31d58dce81a1170ae18005047b2ecdb7f9963e1a957de61beaf4a89d682580ea62e739bdc3045e0cd6402685394 SHA512 8dfcae6e81553bccb093dac2aefdbea6e405ebcf3c3505b4647a4970f46ec8aa2f45690a0fd73ff356d074c86c670ab0a60ff5a049dd1e54de3100457fbae935
diff --git a/media-plugins/kodi-audiodecoder-nosefart/kodi-audiodecoder-nosefart-2.0.0.ebuild b/media-plugins/kodi-audiodecoder-nosefart/kodi-audiodecoder-nosefart-2.0.0.ebuild
new file mode 100644
index 000000000000..5bceea5784f2
--- /dev/null
+++ b/media-plugins/kodi-audiodecoder-nosefart/kodi-audiodecoder-nosefart-2.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Nosefart decoder addon for Kodi"
+HOMEPAGE="https://github.com/notspiff/audiodecoder.nosefart"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/notspiff/audiodecoder.nosefart"
+ inherit git-r3
+ ;;
+*)
+ CODENAME="Leia"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/notspiff/audiodecoder.nosefart/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/audiodecoder.nosefart-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-18*
+ =media-libs/kodi-platform-18*
+ "
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-audiodecoder-nosefart/kodi-audiodecoder-nosefart-9999.ebuild b/media-plugins/kodi-audiodecoder-nosefart/kodi-audiodecoder-nosefart-9999.ebuild
index ace5ee08839f..1266bc7680ef 100644
--- a/media-plugins/kodi-audiodecoder-nosefart/kodi-audiodecoder-nosefart-9999.ebuild
+++ b/media-plugins/kodi-audiodecoder-nosefart/kodi-audiodecoder-nosefart-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,9 +16,10 @@ case ${PV} in
inherit git-r3
;;
*)
+ CODENAME="Leia"
KEYWORDS="~amd64 ~x86"
- SRC_URI="https://github.com/notspiff/audiodecoder.nosefart/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/audiodecoder.nosefart-${PV}"
+ SRC_URI="https://github.com/notspiff/audiodecoder.nosefart/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/audiodecoder.nosefart-${PV}-${CODENAME}"
;;
esac
@@ -27,8 +28,8 @@ SLOT="0"
IUSE=""
DEPEND="
- media-tv/kodi
- media-libs/kodi-platform
+ ~media-tv/kodi-9999
+ ~media-libs/kodi-platform-9999
"
RDEPEND="
${DEPEND}