summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2022-12-01 15:40:48 +0100
committerSam James <sam@gentoo.org>2022-12-24 06:55:50 +0000
commitc9fc0e563e8d4c73be09fd6ae98b679d1927fe8e (patch)
tree99140feb4f3c6743e93005e021232d3ab38b461c /media-plugins
parentmail-filter/spamassassin: add 4.0.0 (diff)
downloadgentoo-c9fc0e563e8d4c73be09fd6ae98b679d1927fe8e.tar.gz
gentoo-c9fc0e563e8d4c73be09fd6ae98b679d1927fe8e.tar.bz2
gentoo-c9fc0e563e8d4c73be09fd6ae98b679d1927fe8e.zip
net-misc/icaclient: bump to 22.12.0.12
Here we do not just bump the version but also change the way we deal with the shared config file between this ebuild and its plugin media-plugins/hdx-realtime-media-engine. Also we move the rdep to sys-libs/llvm-libunwind to the plugin. And if the user wants hdx support on icaclient they have to set a USE flag. The plugin will not work if icaclient is not built with support for it and the plugin itself contains the tool to enable itself so we turn the dep chain around, the plugin is even a bdep of the application. Closes: https://bugs.gentoo.org/883775 Closes: https://bugs.gentoo.org/881637 Signed-off-by: Henning Schild <henning@hennsch.de> Closes: https://github.com/gentoo/gentoo/pull/28493 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/hdx-realtime-media-engine/hdx-realtime-media-engine-2.9.500.2802-r1.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/media-plugins/hdx-realtime-media-engine/hdx-realtime-media-engine-2.9.500.2802-r1.ebuild b/media-plugins/hdx-realtime-media-engine/hdx-realtime-media-engine-2.9.500.2802-r1.ebuild
new file mode 100644
index 000000000000..d72d760272eb
--- /dev/null
+++ b/media-plugins/hdx-realtime-media-engine/hdx-realtime-media-engine-2.9.500.2802-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker
+
+MY_PV="$(ver_cut 1-3)"
+
+DESCRIPTION="HDX RealTime Media Engine plugin for Citrix Workspace App"
+HOMEPAGE="https://www.citrix.com/"
+SRC_URI="amd64? ( HDX_RealTime_Media_Engine_${MY_PV}_for_Linux_x64.zip )
+ x86? ( HDX_RealTime_Media_Engine_${MY_PV}_for_Linux.zip )"
+LICENSE="icaclient"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+RESTRICT="fetch mirror strip"
+
+BDEPEND="app-arch/unzip"
+RDEPEND="
+ sys-libs/llvm-libunwind
+ || (
+ media-video/pipewire
+ media-sound/pulseaudio
+ media-sound/apulse
+ )
+ !<net-misc/icaclient-22.12.0.12
+"
+
+ICAROOT="/opt/Citrix/ICAClient"
+QA_PREBUILT="${ICAROOT#/}/*"
+
+S="${WORKDIR}/usr/local/bin"
+
+pkg_nofetch() {
+ elog "Download the client file ${A} from"
+ elog "https://www.citrix.com/de-de/downloads/citrix-receiver/additional-client-software/hdx-realtime-media-engine-ltsrcu-latest.html"
+ elog "and place it into your DISTDIR directory."
+}
+
+pkg_setup() {
+ case ${ARCH} in
+ amd64)
+ zip_dir="x86_64"
+ zip_arch="amd64"
+ ;;
+ x86)
+ zip_dir="i386"
+ zip_arch="i386"
+ ;;
+ esac
+}
+
+src_unpack() {
+ default
+
+ local MY_T="${WORKDIR}/HDX_RealTime_Media_Engine_${MY_PV}_for_Linux$(usex amd64 '_x64' '')"
+ local deb_base_name="citrix-hdx-realtime-media-engine"
+ unpack_deb ${MY_T}/${zip_dir}/${deb_base_name}_$(ver_rs 3 -)_${zip_arch}.deb
+}
+
+src_install() {
+ insinto "${ICAROOT}/rtme"
+
+ # No, we do NOT install such a generic udev rule into the system
+ local destfiles=(
+ DialTone_US.wav
+ EULA.rtf
+ InboundCallRing.wav
+ )
+
+ local el
+ for el in "${destfiles[@]}" ; do
+ doins "${el}"
+ done
+
+ exeinto "${ICAROOT}"/rtme
+ doexe RTMEconfig RTMediaEngineSRV
+
+ for el in /var/{lib,log}/RTMediaEngineSRV /var/lib/Citrix/HDXRMEP ; do
+ keepdir ${el}
+ fperms a+rw ${el}
+ done
+
+ insinto "${ICAROOT}"
+ doins HDXRTME.so
+}