summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-08-05 10:19:40 -0400
committerCraig Andrews <candrews@gentoo.org>2019-08-05 10:21:09 -0400
commitcc390985a0349d434ad40b3546dedbf9102ad19b (patch)
tree05c370a2c47ce939689d188e9282766430db71d7 /media-plugins
parentmedia-plugins/kodi-game-libretro-bnes: 0.83.0.4 version bump (diff)
downloadgentoo-cc390985a0349d434ad40b3546dedbf9102ad19b.tar.gz
gentoo-cc390985a0349d434ad40b3546dedbf9102ad19b.tar.bz2
gentoo-cc390985a0349d434ad40b3546dedbf9102ad19b.zip
media-plugins/kodi-game-libretro-nestopia: 1.50.0.4 version bump
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/kodi-game-libretro-nestopia/Manifest1
-rw-r--r--media-plugins/kodi-game-libretro-nestopia/kodi-game-libretro-nestopia-1.50.0.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/media-plugins/kodi-game-libretro-nestopia/Manifest b/media-plugins/kodi-game-libretro-nestopia/Manifest
index 00cff3df3ac9..cea39c1d2e02 100644
--- a/media-plugins/kodi-game-libretro-nestopia/Manifest
+++ b/media-plugins/kodi-game-libretro-nestopia/Manifest
@@ -1 +1,2 @@
DIST kodi-game-libretro-nestopia-1.50.0.3.tar.gz 793893 BLAKE2B 89015bb8c687685264e4a8c34cf1caad87cfa1a3611cbd67b540ddb31e9e75049eed328b51c69702e92e358a659d4e503ccdac1b52b7db70688e1236529536ad SHA512 4c41db8c77d24301f00b9d0283c948ae3c4176228e733a316fa5b2eba60ceea4dd094f48270d545008f144d3316cf5f8f190017f70e8378b9fbcbcdb2d8220e6
+DIST kodi-game-libretro-nestopia-1.50.0.4.tar.gz 793616 BLAKE2B 29bbf63f7ef66abf0756399760d882685b4b58cf8a2ac23ce879ea7c7941425828f2bc2d929326ffc3dd7eb51259fdba49264594f2d0759bc20cc6a05a8ca5ac SHA512 58535b305d1aa6ba498c07cbfad09efcfd0e8dd7f251fb973188beeacd07d3ebfa48c639e73a07501019acb88e29cf1ff1b8a685235d7ef69cedb127bba6e44e
diff --git a/media-plugins/kodi-game-libretro-nestopia/kodi-game-libretro-nestopia-1.50.0.4.ebuild b/media-plugins/kodi-game-libretro-nestopia/kodi-game-libretro-nestopia-1.50.0.4.ebuild
new file mode 100644
index 000000000000..49c4284c2283
--- /dev/null
+++ b/media-plugins/kodi-game-libretro-nestopia/kodi-game-libretro-nestopia-1.50.0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Nestopia GameClient for Kodi"
+HOMEPAGE="https://github.com/kodi-game/game.libretro.nestopia"
+SRC_URI=""
+
+if [[ ${PV} == *9999 ]]; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/kodi-game/game.libretro.nestopia.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ CODENAME="Leia"
+ SRC_URI="https://github.com/kodi-game/game.libretro.nestopia/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/game.libretro.nestopia-${PV}-${CODENAME}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-18*
+ games-emulation/libretro-nestopia
+ "
+RDEPEND="
+ media-plugins/kodi-game-libretro
+ ${DEPEND}
+ "
+src_prepare() {
+ echo 'find_library(NESTOPIA_LIB NAMES nestopia_libretro${CMAKE_SHARED_LIBRARY_SUFFIX} PATH_SUFFIXES libretro)' > "${S}/Findlibretro-nestopia.cmake" || die
+ default
+}