summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2021-04-05 11:05:54 +0200
committerJoerg Bornkessel <hd_brummy@gentoo.org>2021-04-05 11:06:47 +0200
commiteb20013b2a9e72a1dbc298ed65051201e14502f1 (patch)
treeeb718539760b69735f13e364c889e88458ef15ba /media-plugins
parentdev-lang/julia: Bump to 1.6.0 (diff)
downloadgentoo-eb20013b2a9e72a1dbc298ed65051201e14502f1.tar.gz
gentoo-eb20013b2a9e72a1dbc298ed65051201e14502f1.tar.bz2
gentoo-eb20013b2a9e72a1dbc298ed65051201e14502f1.zip
media-plugins/vdr-xineliboutput: calls cc directly fixed
this commit will also fix the compile with llvm/clang, the llvm/clang patch will fix only the errors to prevent the plugin from compile, a lot of warnings on llvm/clang are still exist Closes: https://bugs.gentoo.org/771036 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-xineliboutput/Manifest2
-rw-r--r--media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.1.0-r1.ebuild149
-rw-r--r--media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0-r1.ebuild148
-rw-r--r--media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0-r3.ebuild (renamed from media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.1.0-r2.ebuild)11
4 files changed, 8 insertions, 302 deletions
diff --git a/media-plugins/vdr-xineliboutput/Manifest b/media-plugins/vdr-xineliboutput/Manifest
index b3eae169dc54..5e7390958091 100644
--- a/media-plugins/vdr-xineliboutput/Manifest
+++ b/media-plugins/vdr-xineliboutput/Manifest
@@ -1,2 +1,2 @@
-DIST vdr-xineliboutput-2.1.0.tgz 415333 BLAKE2B 8311271dda889cde5ab69d5bf1f643c8f6b1991ca615ce6322ea5585aac12b07b32f6fd933bf6c3797d45971597e61d429e4d9de356246109cab7c8f059b4d79 SHA512 226654dcd47864e9df8282ef401509d291677587b2850872c535abb7bee468a7c6d72c30953090890d002f0977aa1ee357a0fe6938ce3f3c1b6324e82b926537
DIST vdr-xineliboutput-2.2.0.tgz 426058 BLAKE2B 8a5e325e0dd45dffdbcf1b9e49d4ae2486d3b3c7585dbca81855264a0a9057c48da7626acd5e9d7b2113b200eead178b19a0d9834ace5d25cd97157912d50bfa SHA512 d3b753fe496c6f73d491195cc1dac3333a46f2ef6350683fc15e3e8a423a90946574c3fdf0ed43727d61f007a8abdf3041e274317216bf06a8146dc9206f88d9
+DIST vdr-xineliboutput-2.2.0_c++11.patch.bz2 7609 BLAKE2B fe3b9f8d8fb1425e11e068a410844c2ad4f7afa60ad815ee0918a9ce2fa16e450b418358f7688047a5d5b185bb783890a31cfa174d7dc4b29deb9d96f9295fbd SHA512 8323b73b082ef61fe74ef1110e991c8f8acfcf22ac8ddd9f06cd5f8cba6d0087a5500658e20402b8b590a1bb4f10ad7bf712be12a11c447f943aafa4a32413e3
diff --git a/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.1.0-r1.ebuild b/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.1.0-r1.ebuild
deleted file mode 100644
index 26cc8d658f5c..000000000000
--- a/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.1.0-r1.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic toolchain-funcs vdr-plugin-2
-
-GENTOO_VDR_CONDITIONAL=yes
-
-DESCRIPTION="VDR Plugin: Xinelib PlugIn"
-HOMEPAGE="https://sourceforge.net/projects/xineliboutput/"
-SRC_URI="mirror://sourceforge/${PN#vdr-}/${P}.tgz"
-
-SLOT="0"
-LICENSE="GPL-2+"
-KEYWORDS="~amd64 ~x86"
-IUSE="bluray caps cec dbus fbcon jpeg libextractor nls opengl +vdr vaapi vdpau +X +xine xinerama"
-
-COMMON_DEPEND="
- vdr? (
- media-video/vdr
- libextractor? ( >=media-libs/libextractor-0.5.20 )
- caps? ( sys-libs/libcap )
- )
-
- xine? (
- ( >=media-libs/xine-lib-1.2
- media-video/ffmpeg )
- fbcon? ( jpeg? ( virtual/jpeg:* ) )
- X? (
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXrender
- bluray? ( media-libs/libbluray )
- dbus? ( dev-libs/dbus-glib dev-libs/glib:2 )
- jpeg? ( virtual/jpeg:* )
- opengl? ( virtual/opengl )
- vaapi? ( x11-libs/libva >=media-libs/xine-lib-1.2[vaapi] )
- vdpau? ( x11-libs/libvdpau >=media-libs/xine-lib-1.2[vdpau] )
- xinerama? ( x11-libs/libXinerama )
- )
- )"
-
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- sys-kernel/linux-headers
- nls? ( sys-devel/gettext )
- xine? (
- X? (
- x11-base/xorg-proto
- x11-libs/libXxf86vm
- )
- )"
-RDEPEND="${COMMON_DEPEND}"
-
-REQUIRED_USE=" || ( vdr xine )"
-
-VDR_CONFD_FILE="${FILESDIR}/confd-2.0.0"
-
-pkg_setup() {
- vdr-plugin-2_pkg_setup
-
- if use xine; then
- XINE_PLUGIN_DIR=$(pkg-config --variable=plugindir libxine)
- [ -z "${XINE_PLUGIN_DIR}" ] && die "Could not find xine plugin dir"
- fi
-}
-
-src_configure() {
- local myconf
-
- if has_version ">=media-libs/xine-lib-1.2"; then
- myconf="${myconf} --enable-libavutil"
- else
- myconf="${myconf} --disable-libavutil"
- fi
-
- # No autotools based configure script
- ./configure \
- --cc=$(tc-getCC) \
- --cxx=$(tc-getCXX) \
- $(use_enable X x11) \
- $(use_enable X xshm) \
- $(use_enable X xdpms) \
- $(use_enable X xshape) \
- $(use_enable X xrandr) \
- $(use_enable X xrender) \
- $(use_enable fbcon fb) \
- $(use_enable vdr) \
- $(use_enable xine libxine) \
- $(use_enable libextractor) \
- $(use_enable caps libcap) \
- $(use_enable cec libcec) \
- $(use_enable jpeg libjpeg) \
- $(use_enable xinerama) \
- $(use_enable vdpau) \
- $(use_enable dbus dbus-glib-1) \
- $(use_enable nls i18n) \
- $(use_enable bluray libbluray) \
- $(use_enable opengl) \
- ${myconf} \
- || die
-
- # UINT64_C is needed by ffmpeg headers
- append-cxxflags -D__STDC_CONSTANT_MACROS
-}
-
-src_install() {
- if use vdr; then
- vdr-plugin-2_src_install
-
- # bug 346989
- insinto /etc/vdr/plugins/xineliboutput/
- doins examples/allowed_hosts.conf
- fowners -R vdr:vdr /etc/vdr/
-
- if use nls; then
- emake DESTDIR="${D}" i18n
- fi
-
- if use xine; then
- doinitd "${FILESDIR}"/vdr-frontend
-
- insinto $XINE_PLUGIN_DIR
- doins xineplug_inp_xvdr.so
-
- insinto $XINE_PLUGIN_DIR/post
- doins xineplug_post_*.so
-
- if use fbcon; then
- dobin vdr-fbfe
-
- insinto $VDR_PLUGIN_DIR
- doins libxineliboutput-fbfe.so.*
- fi
-
- if use X; then
- dobin vdr-sxfe
-
- insinto $VDR_PLUGIN_DIR
- doins libxineliboutput-sxfe.so.*
- fi
- fi
- else
- emake DESTDIR="${D}" install
-
- dodoc HISTORY README
- fi
-}
diff --git a/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0-r1.ebuild b/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0-r1.ebuild
deleted file mode 100644
index 5f905220218f..000000000000
--- a/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0-r1.ebuild
+++ /dev/null
@@ -1,148 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic toolchain-funcs vdr-plugin-2
-
-GENTOO_VDR_CONDITIONAL=yes
-
-DESCRIPTION="VDR Plugin: Xinelib PlugIn"
-HOMEPAGE="https://sourceforge.net/projects/xineliboutput/"
-SRC_URI="mirror://sourceforge/${PN#vdr-}/${P}.tgz"
-
-SLOT="0"
-LICENSE="GPL-2+"
-KEYWORDS="~amd64 ~x86"
-IUSE="bluray caps cec dbus fbcon jpeg libextractor nls opengl +vdr vaapi vdpau +X +xine xinerama"
-
-COMMON_DEPEND="
- vdr? (
- media-video/vdr
- libextractor? ( >=media-libs/libextractor-0.5.20 )
- caps? ( sys-libs/libcap )
- )
-
- xine? (
- ( >=media-libs/xine-lib-1.2
- media-video/ffmpeg )
- fbcon? ( jpeg? ( virtual/jpeg:* ) )
- X? (
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXrender
- bluray? ( media-libs/libbluray )
- dbus? ( dev-libs/dbus-glib dev-libs/glib:2 )
- jpeg? ( virtual/jpeg:* )
- opengl? ( virtual/opengl )
- vaapi? ( x11-libs/libva >=media-libs/xine-lib-1.2[vaapi] )
- vdpau? ( x11-libs/libvdpau >=media-libs/xine-lib-1.2[vdpau] )
- xinerama? ( x11-libs/libXinerama )
- )
- )"
-
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- sys-kernel/linux-headers
- nls? ( sys-devel/gettext )
- xine? (
- X? (
- x11-base/xorg-proto
- x11-libs/libXxf86vm
- )
- )"
-RDEPEND="${COMMON_DEPEND}"
-
-REQUIRED_USE=" || ( vdr xine )"
-
-VDR_CONFD_FILE="${FILESDIR}/confd-2.0.0"
-
-pkg_setup() {
- vdr-plugin-2_pkg_setup
-
- if use xine; then
- XINE_PLUGIN_DIR=$(pkg-config --variable=plugindir libxine)
- [ -z "${XINE_PLUGIN_DIR}" ] && die "Could not find xine plugin dir"
- fi
-}
-
-src_configure() {
- local myconf
-
- if has_version ">=media-libs/xine-lib-1.2"; then
- myconf="${myconf} --enable-libavutil"
- else
- myconf="${myconf} --disable-libavutil"
- fi
-
- # No autotools based configure script
- ./configure \
- --cc=$(tc-getCC) \
- --cxx=$(tc-getCXX) \
- $(use_enable X x11) \
- $(use_enable X xshm) \
- $(use_enable X xdpms) \
- $(use_enable X xshape) \
- $(use_enable X xrandr) \
- $(use_enable X xrender) \
- $(use_enable fbcon fb) \
- $(use_enable vdr) \
- $(use_enable xine libxine) \
- $(use_enable libextractor) \
- $(use_enable caps libcap) \
- $(use_enable cec libcec) \
- $(use_enable jpeg libjpeg) \
- $(use_enable xinerama) \
- $(use_enable dbus dbus-glib-1) \
- $(use_enable nls i18n) \
- $(use_enable bluray libbluray) \
- $(use_enable opengl) \
- ${myconf} \
- || die
-
- # UINT64_C is needed by ffmpeg headers
- append-cxxflags -D__STDC_CONSTANT_MACROS
-}
-
-src_install() {
- if use vdr; then
- vdr-plugin-2_src_install
-
- # bug 346989
- insinto /etc/vdr/plugins/xineliboutput/
- doins examples/allowed_hosts.conf
- fowners -R vdr:vdr /etc/vdr/
-
- if use nls; then
- emake DESTDIR="${D}" i18n
- fi
-
- if use xine; then
- doinitd "${FILESDIR}"/vdr-frontend
-
- insinto $XINE_PLUGIN_DIR
- doins xineplug_inp_xvdr.so
-
- insinto $XINE_PLUGIN_DIR/post
- doins xineplug_post_*.so
-
- if use fbcon; then
- dobin vdr-fbfe
-
- insinto $VDR_PLUGIN_DIR
- doins libxineliboutput-fbfe.so.*
- fi
-
- if use X; then
- dobin vdr-sxfe
-
- insinto $VDR_PLUGIN_DIR
- doins libxineliboutput-sxfe.so.*
- fi
- fi
- else
- emake DESTDIR="${D}" install
-
- dodoc HISTORY README
- fi
-}
diff --git a/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.1.0-r2.ebuild b/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0-r3.ebuild
index 22b0356c3c50..beec586bcb2e 100644
--- a/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.1.0-r2.ebuild
+++ b/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0-r3.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic toolchain-funcs vdr-plugin-2
+inherit vdr-plugin-2
GENTOO_VDR_CONDITIONAL=yes
DESCRIPTION="VDR Plugin: Xinelib PlugIn"
HOMEPAGE="https://sourceforge.net/projects/xineliboutput/"
-SRC_URI="mirror://sourceforge/${PN#vdr-}/${P}.tgz"
+SRC_URI="mirror://sourceforge/${PN#vdr-}/${P}.tgz
+ http://vdr.websitec.de/download/${PN}/${P}_c++11.patch.bz2"
SLOT="0"
LICENSE="GPL-2+"
@@ -71,6 +72,9 @@ src_prepare() {
# bug 711978
sed -e "s:X11 opengl:X11 OpenGl:" -i configure || die
+
+ # bug 771036, fix compile llvm/clang
+ eapply "${WORKDIR}/${P}_c++11.patch"
}
src_configure() {
@@ -100,7 +104,6 @@ src_configure() {
$(use_enable cec libcec) \
$(use_enable jpeg libjpeg) \
$(use_enable xinerama) \
- $(use_enable vdpau) \
$(use_enable dbus dbus-glib-1) \
$(use_enable nls i18n) \
$(use_enable bluray libbluray) \