summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2019-05-02 16:39:09 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-08 18:59:32 +0200
commite380f1800555eabaa84f913bdafadd39070e44e3 (patch)
treecfb0646f35df40ecf66b64f4f4d1b16884a1e71a /media-radio/KochMorse
parentdev-util/quilt: adjust patch to -p1 (diff)
downloadgentoo-e380f1800555eabaa84f913bdafadd39070e44e3.tar.gz
gentoo-e380f1800555eabaa84f913bdafadd39070e44e3.tar.bz2
gentoo-e380f1800555eabaa84f913bdafadd39070e44e3.zip
media-radio/KochMorse: Updated DEPEND, RDEPEND
Closes: https://bugs.gentoo.org/684890 Signed-off-by: Ralph Seichter <gentoo@seichter.de> Package-Manager: Portage-2.3.62, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/11878 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-radio/KochMorse')
-rw-r--r--media-radio/KochMorse/KochMorse-3.4.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-radio/KochMorse/KochMorse-3.4.0-r1.ebuild b/media-radio/KochMorse/KochMorse-3.4.0-r1.ebuild
new file mode 100644
index 000000000000..7fb3da7984f0
--- /dev/null
+++ b/media-radio/KochMorse/KochMorse-3.4.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Morse-code tutor using the Koch method"
+HOMEPAGE="https://github.com/hmatuschek/kochmorse"
+SRC_URI="https://github.com/hmatuschek/kochmorse/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtwidgets:5"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5"
+
+S="${WORKDIR}/kochmorse-${PV}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ # Upstream uses a non-standard category in release 3.4.0. I submitted
+ # a fix which has been accepted, but not yet released.
+ sed -i -e 's/Teaching;/X-Teaching;/' shared/kochmorse.desktop || die
+}