summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2015-12-29 07:23:41 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2015-12-29 07:23:41 +0100
commit5a9f4b981051cfbb0f13922971722721184a4764 (patch)
tree05c9ca97924b19e0fadbc29fd878cab96a6d127b /media-radio/cwdaemon/cwdaemon-0.10.2.ebuild
parentapp-text/referencer: bump to vn. 1.2.2 (diff)
downloadgentoo-5a9f4b981051cfbb0f13922971722721184a4764.tar.gz
gentoo-5a9f4b981051cfbb0f13922971722721184a4764.tar.bz2
gentoo-5a9f4b981051cfbb0f13922971722721184a4764.zip
media-radio/cwdaemon: Fix missing headers for gcc>=5 (bug #569970)
Thanks for reporting Toralf. Package-Manager: portage-2.2.26
Diffstat (limited to 'media-radio/cwdaemon/cwdaemon-0.10.2.ebuild')
-rw-r--r--media-radio/cwdaemon/cwdaemon-0.10.2.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/media-radio/cwdaemon/cwdaemon-0.10.2.ebuild b/media-radio/cwdaemon/cwdaemon-0.10.2.ebuild
index bb0475bff629..c27eb1ba3290 100644
--- a/media-radio/cwdaemon/cwdaemon-0.10.2.ebuild
+++ b/media-radio/cwdaemon/cwdaemon-0.10.2.ebuild
@@ -4,6 +4,8 @@
EAPI=5
+inherit flag-o-matic
+
DESCRIPTION="A morse daemon for the parallel or serial port"
HOMEPAGE="http://cwdaemon.sourceforge.net"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
@@ -16,3 +18,9 @@ IUSE=""
RDEPEND=">=media-radio/unixcw-3.3.1"
DEPEND="$RDEPEND
virtual/pkgconfig"
+
+src_configure() {
+ # provides header info for getaddrinfo() with C99 (bug 569970)
+ append-cppflags -D_GNU_SOURCE
+ econf
+}