summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2017-12-22 08:22:37 -0500
committerRichard Freeman <rich0@gentoo.org>2017-12-22 08:22:37 -0500
commita22a196dc8261afc91f6b8b397e2ba48a3f56981 (patch)
treea2b41fc61072dc4481eb234c147195b6edf61ad3 /media-radio/direwolf/direwolf-1.4.ebuild
parentmedia-radio/tqsl: introduce package from rich0 overlay (diff)
downloadgentoo-a22a196dc8261afc91f6b8b397e2ba48a3f56981.tar.gz
gentoo-a22a196dc8261afc91f6b8b397e2ba48a3f56981.tar.bz2
gentoo-a22a196dc8261afc91f6b8b397e2ba48a3f56981.zip
media-radio/direwolf: introduce package from rich0 overlay
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'media-radio/direwolf/direwolf-1.4.ebuild')
-rw-r--r--media-radio/direwolf/direwolf-1.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-radio/direwolf/direwolf-1.4.ebuild b/media-radio/direwolf/direwolf-1.4.ebuild
new file mode 100644
index 000000000000..04a0995bbf20
--- /dev/null
+++ b/media-radio/direwolf/direwolf-1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils systemd
+
+DESCRIPTION="Decoded Information from Radio Emissions for Windows Or Linux Fans"
+HOMEPAGE="https://github.com/wb2osz/direwolf/blob/master/README.md"
+SRC_URI="https://github.com/wb2osz/direwolf/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib:="
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGES.md README.md doc/2400-4800-PSK-for-APRS-Packet-Radio.pdf doc/A-Better-APRS-Packet-Demodulator-Part-1-1200-baud.pdf doc/A-Better-APRS-Packet-Demodulator-Part-2-9600-baud.pdf doc/A-Closer-Look-at-the-WA8LMF-TNC-Test-CD.pdf doc/APRS-Telemetry-Toolkit.pdf doc/APRStt-Implementation-Notes.pdf doc/APRStt-interface-for-SARTrack.pdf doc/APRStt-Listening-Example.pdf doc/Going-beyond-9600-baud.pdf doc/Raspberry-Pi-APRS.pdf doc/Raspberry-Pi-APRS-Tracker.pdf doc/Raspberry-Pi-SDR-IGate.pdf doc/README.md doc/Successful-APRS-IGate-Operation.pdf doc/User-Guide.pdf doc/WA8LMF-TNC-Test-CD-Results.pdf direwolf.conf dw-start.sh sdr.conf telemetry-toolkit/telem-m0xer-3.txt telemetry-toolkit/telem-balloon.conf telemetry-toolkit/telem-volts.conf )
+
+INSTALLDIR="${D}"
+
+src_prepare() {
+ eapply_user
+ epatch "${FILESDIR}/${PV}-makefile.patch"
+}
+
+src_install() {
+ dodir /usr
+ dodir /usr/bin
+ dodir /var/log/direwolf
+ emake DESTDIR="${D}" install
+ insinto /etc/direwolf/
+ doins direwolf.conf
+ einstalldocs
+ systemd_dounit "${FILESDIR}"/direwolf.service
+ systemd_dounit "${FILESDIR}"/direwolf-kiss.service
+}