summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJannis Achstetter <kripton@kripserver.net>2020-09-13 16:42:05 +0200
committerRichard Freeman <rich0@gentoo.org>2020-10-23 15:52:50 -0400
commit851cb3b5ceb043715584d238e84b9fd69f7356c3 (patch)
tree501a52b1446cb4197265c0830cdff0982b27cda3 /media-radio/direwolf/direwolf-1.5.ebuild
parentdev-libs/libfilezilla: Removed old (diff)
downloadgentoo-851cb3b5ceb043715584d238e84b9fd69f7356c3.tar.gz
gentoo-851cb3b5ceb043715584d238e84b9fd69f7356c3.tar.bz2
gentoo-851cb3b5ceb043715584d238e84b9fd69f7356c3.zip
media-radio/direwolf: Bump to v1.5
Closes: https://bugs.gentoo.org/681666 Closes: https://bugs.gentoo.org/705100 Closes: https://bugs.gentoo.org/724720 Closes: https://bugs.gentoo.org/727636 Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Jannis Achstetter <kripton@kripserver.net> Closes: https://github.com/gentoo/gentoo/pull/17530 Signed-off-by: Richard Freeman <rich0@gentoo.org>
Diffstat (limited to 'media-radio/direwolf/direwolf-1.5.ebuild')
-rw-r--r--media-radio/direwolf/direwolf-1.5.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-radio/direwolf/direwolf-1.5.ebuild b/media-radio/direwolf/direwolf-1.5.ebuild
new file mode 100644
index 000000000000..deaf27c9ab1d
--- /dev/null
+++ b/media-radio/direwolf/direwolf-1.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils systemd
+
+DESCRIPTION="Decoded Information from Radio Emissions for Windows Or Linux Fans"
+HOMEPAGE="https://github.com/wb2osz/direwolf/blob/master/README.md"
+SRC_URI="https://github.com/wb2osz/direwolf/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gps hamlib udev"
+
+RDEPEND="
+ media-libs/alsa-lib:=
+ gps? ( sci-geosciences/gpsd )
+ hamlib? ( media-libs/hamlib )
+ udev? ( virtual/libudev )
+"
+BDEPEND="hamlib? ( virtual/pkgconfig )"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGES.md README.md doc/2400-4800-PSK-for-APRS-Packet-Radio.pdf doc/A-Better-APRS-Packet-Demodulator-Part-1-1200-baud.pdf doc/A-Better-APRS-Packet-Demodulator-Part-2-9600-baud.pdf doc/A-Closer-Look-at-the-WA8LMF-TNC-Test-CD.pdf doc/APRS-Telemetry-Toolkit.pdf doc/APRStt-Implementation-Notes.pdf doc/APRStt-interface-for-SARTrack.pdf doc/APRStt-Listening-Example.pdf doc/Going-beyond-9600-baud.pdf doc/Raspberry-Pi-APRS.pdf doc/Raspberry-Pi-APRS-Tracker.pdf doc/Raspberry-Pi-SDR-IGate.pdf doc/README.md doc/Successful-APRS-IGate-Operation.pdf doc/User-Guide.pdf doc/WA8LMF-TNC-Test-CD-Results.pdf direwolf.conf dw-start.sh sdr.conf telemetry-toolkit/telem-m0xer-3.txt telemetry-toolkit/telem-balloon.conf telemetry-toolkit/telem-volts.conf )
+
+INSTALLDIR="${D}"
+
+src_prepare() {
+ eapply "${FILESDIR}/${PV}-makefile.patch"
+ eapply "${FILESDIR}/direwolf-gpsd-API-9.patch"
+
+ eapply_user
+
+ if use gps ; then
+ sed -i -e 's/#enable_gpsd/enable_gpsd/' Makefile.linux || die "Sed failed!"
+ fi
+
+ if use hamlib; then
+ sed -i -e 's/#enable_hamlib/enable_hamlib/' Makefile.linux || die "Sed failed!"
+ fi
+
+ if use udev ; then
+ sed -i -e 's/#enable_cm108/enable_cm108/' Makefile.linux || die "Sed failed!"
+ fi
+}
+
+src_install() {
+ dodir /usr
+ dodir /usr/bin
+ keepdir /var/log/direwolf
+ emake DESTDIR="${D}" install
+ insinto /etc/direwolf/
+ doins direwolf.conf
+ einstalldocs
+ systemd_dounit "${FILESDIR}"/direwolf.service
+ systemd_dounit "${FILESDIR}"/direwolf-kiss.service
+}