summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-13 05:43:16 +0000
committerSam James <sam@gentoo.org>2022-03-13 05:43:16 +0000
commitc319d22e5ffeaaa58054a136a31ac3fb395b3f25 (patch)
treed14beee5da46a500d15b9154be68ae19cb70f537 /media-radio/gpredict
parentapp-crypt/codecrypt: fix use_with cosmetics (diff)
downloadgentoo-c319d22e5ffeaaa58054a136a31ac3fb395b3f25.tar.gz
gentoo-c319d22e5ffeaaa58054a136a31ac3fb395b3f25.tar.bz2
gentoo-c319d22e5ffeaaa58054a136a31ac3fb395b3f25.zip
media-radio/gpredict: [QA] use eautoreconf
Use eautoreconf instead of autogen.sh (handles everything we need, plus inheriting autotools.eclass guarantees correct dependencies). Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-radio/gpredict')
-rw-r--r--media-radio/gpredict/gpredict-2.3-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-radio/gpredict/gpredict-2.3-r1.ebuild b/media-radio/gpredict/gpredict-2.3-r1.ebuild
new file mode 100644
index 000000000000..a24b2f3a6e4b
--- /dev/null
+++ b/media-radio/gpredict/gpredict-2.3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Real-time satellite tracking and orbit prediction application"
+HOMEPAGE="http://gpredict.oz9aec.net"
+SRC_URI="https://github.com/csete/gpredict/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gdk-pixbuf[jpeg]
+ x11-libs/gtk+:3
+ x11-libs/goocanvas:2.0
+ net-misc/curl"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README )
+
+src_prepare() {
+ eapply_user
+ # remove wrong doc location
+ eapply "${FILESDIR}/${P}-doc.patch"
+ eapply "${FILESDIR}/${PN}-2.2.1-fno-common.patch"
+
+ eautoreconf
+}