summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-radio/ibp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-radio/ibp')
-rw-r--r--media-radio/ibp/Manifest1
-rw-r--r--media-radio/ibp/ibp-0.21.ebuild47
-rw-r--r--media-radio/ibp/metadata.xml8
3 files changed, 56 insertions, 0 deletions
diff --git a/media-radio/ibp/Manifest b/media-radio/ibp/Manifest
new file mode 100644
index 000000000000..b5cc49d12406
--- /dev/null
+++ b/media-radio/ibp/Manifest
@@ -0,0 +1 @@
+DIST ibp-0.21.tgz 33536 SHA256 b3b118ca83619f0a5605652a0a8c385c77ada3a10321a771e2d19f9f59604abd SHA512 784bdcae61ce41dff7d88eb2068171dafa607012660393188326e94e323fdf5badebf3d8a24016c83c96c770b6d0935fc35aef5aca6bbfd665b7f2ccf39118ca WHIRLPOOL f3ebf23a5d797b564e8669aad0cbd8827e5dfc01f13f5b24c6d268f9e1a16be143eaf5257755d47efbccab8ab99e1caa113671509bc04ea3ded9850caba037a7
diff --git a/media-radio/ibp/ibp-0.21.ebuild b/media-radio/ibp/ibp-0.21.ebuild
new file mode 100644
index 000000000000..96d6ce514f1b
--- /dev/null
+++ b/media-radio/ibp/ibp-0.21.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Shows currently transmitting beacons of the International Beacon Project (IBP)"
+HOMEPAGE="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/${PN}.html"
+SRC_URI="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="X"
+
+RDEPEND="sys-libs/ncurses
+ X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}
+ X? ( x11-misc/imake )"
+
+src_prepare() {
+ # respect CFLAGS if built without USE=X
+ sed -i -e "s/= -D/+= -D/" Makefile || die
+}
+
+src_configure() {
+ if use X ;then
+ xmkmf || die
+ fi
+}
+
+src_compile() {
+ if use X ; then
+ emake \
+ CC="$(tc-getCC)" \
+ LOCAL_LDFLAGS="${LDFLAGS}" \
+ CDEBUGFLAGS="${CFLAGS}"
+ else
+ emake CC="$(tc-getCC)"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}
diff --git a/media-radio/ibp/metadata.xml b/media-radio/ibp/metadata.xml
new file mode 100644
index 000000000000..835c76cab148
--- /dev/null
+++ b/media-radio/ibp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tomjbe@gentoo.org</email>
+ <name>Thomas Beierlein</name>
+ </maintainer>
+</pkgmetadata>