summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 09:12:10 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:10:55 +0100
commit785024c0fdf0e3d70e94738c40192175d6d60cb6 (patch)
tree0f2c58f8527b38bc157077c33b70c1e0db2f33a9 /media-radio/qrq
parentmedia-radio/direwolf: respect PKG_CONFIG (diff)
downloadgentoo-785024c0fdf0e3d70e94738c40192175d6d60cb6.tar.gz
gentoo-785024c0fdf0e3d70e94738c40192175d6d60cb6.tar.bz2
gentoo-785024c0fdf0e3d70e94738c40192175d6d60cb6.zip
media-radio/qrq: respect PKG_CONFIG, depend on pkgconfig
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-radio/qrq')
-rw-r--r--media-radio/qrq/files/qrq-0.3.2-tinfo.patch8
-rw-r--r--media-radio/qrq/qrq-0.3.3.ebuild9
2 files changed, 10 insertions, 7 deletions
diff --git a/media-radio/qrq/files/qrq-0.3.2-tinfo.patch b/media-radio/qrq/files/qrq-0.3.2-tinfo.patch
index 6a0f38d18fab..90c26ab6220a 100644
--- a/media-radio/qrq/files/qrq-0.3.2-tinfo.patch
+++ b/media-radio/qrq/files/qrq-0.3.2-tinfo.patch
@@ -1,11 +1,11 @@
---- a/Makefile 2019-04-19 16:16:08.354994946 +0200
-+++ b/Makefile 2019-04-19 16:18:30.711734410 +0200
+--- a/Makefile
++++ b/Makefile
@@ -56,7 +56,7 @@
endif
else ifeq ($(USE_PA), YES)
CFLAGS:=$(CFLAGS) -D PA -pthread
- LDFLAGS:=$(LDFLAGS) -lpthread -lpulse-simple -lpulse -lncurses
-+ LDFLAGS:=$(LDFLAGS) -lpthread -lpulse-simple -lpulse $(shell pkg-config ncurses --libs)
++ LDFLAGS:=$(LDFLAGS) -lpthread -lpulse-simple -lpulse $(shell ${PKG_CONFIG} ncurses --libs)
OBJECTS=qrq.o pulseaudio.o
else ifeq ($(USE_WIN32), YES)
CFLAGS:=$(CFLAGS) -D WIN32 -Iinclude -Iinclude/ncursesw
@@ -14,7 +14,7 @@
else
OBJECTS=qrq.o oss.o
- LDFLAGS:=$(LDFLAGS) -lpthread -lncurses
-+ LDFLAGS:=$(LDFLAGS) -lpthread $(shell pkg-config ncurses --libs)
++ LDFLAGS:=$(LDFLAGS) -lpthread $(shell ${PKG_CONFIG} ncurses --libs)
CFLAGS:=$(CFLAGS) -D OSS
endif
diff --git a/media-radio/qrq/qrq-0.3.3.ebuild b/media-radio/qrq/qrq-0.3.3.ebuild
index 18cee98d5be7..6eabc1e68a72 100644
--- a/media-radio/qrq/qrq-0.3.3.ebuild
+++ b/media-radio/qrq/qrq-0.3.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -17,6 +17,7 @@ IUSE="pulseaudio"
DEPEND="sys-libs/ncurses:=
pulseaudio? ( media-sound/pulseaudio )"
RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=( "${FILESDIR}/${PN}-0.3.2-tinfo.patch" )
@@ -28,14 +29,16 @@ src_prepare() {
}
src_compile() {
+ tc-export PKG_CONFIG
+
CONF="USE_PA=NO USE_OSS=YES"
if use pulseaudio; then
CONF="USE_PA=YES USE_OSS=NO"
fi
- emake $CONF
+ emake ${CONF}
}
src_install() {
- emake $CONF DESTDIR="${D}/usr" install
+ emake ${CONF} DESTDIR="${D}/usr" install
dodoc AUTHORS ChangeLog README
}