summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2016-07-24 12:18:44 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2016-07-24 12:18:44 +0200
commitf3077ec012ffa5158decb1c73b5216bf37b6ee46 (patch)
tree0b04a328300b8b06b151b1a04139be8be53576e6 /media-radio/qsstv/qsstv-9.1.8.ebuild
parentapp-backup/bacula: bugfix release for coming gcc-6 (diff)
downloadgentoo-f3077ec012ffa5158decb1c73b5216bf37b6ee46.tar.gz
gentoo-f3077ec012ffa5158decb1c73b5216bf37b6ee46.tar.bz2
gentoo-f3077ec012ffa5158decb1c73b5216bf37b6ee46.zip
media-radio/qsstv: version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'media-radio/qsstv/qsstv-9.1.8.ebuild')
-rw-r--r--media-radio/qsstv/qsstv-9.1.8.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-radio/qsstv/qsstv-9.1.8.ebuild b/media-radio/qsstv/qsstv-9.1.8.ebuild
new file mode 100644
index 000000000000..6f2228faa348
--- /dev/null
+++ b/media-radio/qsstv/qsstv-9.1.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils qt4-r2
+
+MY_P=${P/-/_}
+
+DESCRIPTION="Amateur radio SSTV software"
+HOMEPAGE="http://users.telenet.be/on4qz/"
+SRC_URI="http://users.telenet.be/on4qz/qsstv/downloads/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:4[qt3support]
+ dev-qt/qtgui:4
+ media-libs/hamlib
+ media-libs/openjpeg:2
+ media-libs/alsa-lib
+ media-sound/pulseaudio
+ media-libs/libv4l
+ sci-libs/fftw:3.0"
+RDEPEND="${DEPEND}
+ x11-misc/xdg-utils"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # fix docdirectory, install path and hamlib search path
+ sed -i -e "s:/doc/\$\$TARGET:/doc/${PF}:" \
+ -e "s:-lhamlib:-L/usr/$(get_libdir)/hamlib -lhamlib:g" \
+ qsstv/qsstv.pro || die
+}