summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2018-10-20 11:52:22 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2018-10-20 11:52:58 +0200
commitc98bf2f5b05e7cdcbad2ff9eba2c24af6f460b3b (patch)
treeb4ec7200d7879b2a166cb657bef5204fbc44fb36 /media-radio/tlf/tlf-1.3.1.ebuild
parentapp-xemacs/xslt-process: amd64 stable wrt bug #666312 (diff)
downloadgentoo-c98bf2f5b05e7cdcbad2ff9eba2c24af6f460b3b.tar.gz
gentoo-c98bf2f5b05e7cdcbad2ff9eba2c24af6f460b3b.tar.bz2
gentoo-c98bf2f5b05e7cdcbad2ff9eba2c24af6f460b3b.zip
media-radio/tlf: Version bump
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'media-radio/tlf/tlf-1.3.1.ebuild')
-rw-r--r--media-radio/tlf/tlf-1.3.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-radio/tlf/tlf-1.3.1.ebuild b/media-radio/tlf/tlf-1.3.1.ebuild
new file mode 100644
index 000000000000..6be0473c0593
--- /dev/null
+++ b/media-radio/tlf/tlf-1.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic
+
+DESCRIPTION="Console-mode amateur radio contest logger"
+HOMEPAGE="http://home.iae.nl/users/reinc/TLF-0.2.html"
+SRC_URI="http://www.hs-mittweida.de/tb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="sys-libs/ncurses:=
+ dev-libs/glib:2
+ media-libs/hamlib
+ media-sound/sox
+ dev-libs/xmlrpc-c[curl]"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/cmocka )"
+
+src_configure() {
+ append-ldflags -L/usr/$(get_libdir)/hamlib
+ econf --docdir=/usr/share/doc/${PF} --enable-hamlib --enable-fldigi-xmlrpc
+}