summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2020-03-30 19:29:24 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2020-03-30 20:12:00 +0200
commit04c4732a5628a9e534104a7431a003a18f932367 (patch)
treefd7baf74b490d3cd3a3a6dbee482070edbb53906 /media-radio
parentdev-python/pyopencl: bump to 2019.1.2 (diff)
downloadgentoo-04c4732a5628a9e534104a7431a003a18f932367.tar.gz
gentoo-04c4732a5628a9e534104a7431a003a18f932367.tar.bz2
gentoo-04c4732a5628a9e534104a7431a003a18f932367.zip
media-radio/ax25-apps: Minor version bump
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/ax25-apps/Manifest1
-rw-r--r--media-radio/ax25-apps/ax25-apps-0.0.8_rc5.ebuild49
-rw-r--r--media-radio/ax25-apps/files/ax25-apps-0.0.8_rc5-tinfo.patch14
3 files changed, 64 insertions, 0 deletions
diff --git a/media-radio/ax25-apps/Manifest b/media-radio/ax25-apps/Manifest
index 922a82c89bc7..2d9b3a3d6088 100644
--- a/media-radio/ax25-apps/Manifest
+++ b/media-radio/ax25-apps/Manifest
@@ -1 +1,2 @@
DIST ax25-apps-0.0.8-rc4.tar.gz 442172 BLAKE2B 59a622c0e675cadc90a7d728b899b1820153d6b9e35f3ccdbac74d191f844d1642dd2e9192d6dce0f1208cbc26b98cb1643f8d1041ec3802b833ad5cbc903f81 SHA512 c99b553c5cadb0e389c1cb35e79fea61b628c76f5ef35c35876e492afc7ab796f8781c3ab5987a096f0816389e9772274fe54e88c16fca0fd30013da3d74d38b
+DIST ax25-apps-0.0.8-rc5.tar.gz 479590 BLAKE2B baa4814ebb68c435a9986158dcdad1333376c75202db8e3595ec35851fabb3c718e7015a721d587ee307b8b8c918a690b898addcf4194532f6d26b70219c4c98 SHA512 5886f79dcdd4b02374289e04a61101b1ccdcdd936a6a98bdefa7b091689381de75f722a0bf32a914c85a3759c7b42489fabf74a53492fe2f937b22c953fc230d
diff --git a/media-radio/ax25-apps/ax25-apps-0.0.8_rc5.ebuild b/media-radio/ax25-apps/ax25-apps-0.0.8_rc5.ebuild
new file mode 100644
index 000000000000..939745d86500
--- /dev/null
+++ b/media-radio/ax25-apps/ax25-apps-0.0.8_rc5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+MY_P=${P/_/-}
+
+DESCRIPTION="Basic AX.25 (Amateur Radio) user tools, additional daemons"
+HOMEPAGE="http://www.linux-ax25.org"
+SRC_URI="http://www.linux-ax25.org/pub/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/libax25-0.0.12_rc2
+ sys-libs/ncurses:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ !dev-ruby/listen"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ eapply_user
+ # fix missing prototype for malloc
+ sed -i -e "/^#include /i #include <stdlib.h>" ax25ipd/routing.c || die
+ eapply "$FILESDIR"/$PN-0.0.8_rc5-tinfo.patch
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/ax25ipd.rc ax25ipd
+ newinitd "${FILESDIR}"/ax25mond.rc ax25mond
+ newinitd "${FILESDIR}"/ax25rtd.rc ax25rtd
+
+ rm -rf "${ED}"/usr/share/doc/ax25-apps
+
+ dodoc AUTHORS ChangeLog NEWS README ax25ipd/README.ax25ipd \
+ ax25rtd/README.ax25rtd ax25ipd/HISTORY.ax25ipd ax25rtd/TODO.ax25rtd
+
+ dodir /var/lib/ax25/ax25rtd
+ touch "${ED}"/var/lib/ax25/ax25rtd/ax25_route
+ touch "${ED}"/var/lib/ax25/ax25rtd/ip_route
+}
diff --git a/media-radio/ax25-apps/files/ax25-apps-0.0.8_rc5-tinfo.patch b/media-radio/ax25-apps/files/ax25-apps-0.0.8_rc5-tinfo.patch
new file mode 100644
index 000000000000..7c49d6cbb942
--- /dev/null
+++ b/media-radio/ax25-apps/files/ax25-apps-0.0.8_rc5-tinfo.patch
@@ -0,0 +1,14 @@
+# fix tinfo handling (bug 529776)
+diff --git a/configure.ac b/configure.ac
+index 0c4398a..097d1bd 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -18,7 +18,7 @@ dnl Checks for libraries.
+ AC_SUBST(AX25_LIB)
+ AC_SUBST(NCURSES_LIB)
+ AC_CHECK_LIB(ax25, ax25_config_load_ports, AX25_LIB="-lax25", AC_MSG_ERROR(Could not find the libax25 libraries; aborting))
+-AC_CHECK_LIB(ncursesw, initscr,NCURSES_LIB="-lncursesw", AC_MSG_ERROR(Could not find the ncursesw library; aborting))
++PKG_CHECK_MODULES(ncursesw, ncursesw, [NCURSES_LIB="$ncursesw_LIBS"], AC_MSG_ERROR(Could not find the ncursesw library; aborting))
+
+ dnl Checks for working glibc 2.1 headers
+ AC_CHECK_TYPES([struct ax25_fwd_struct], [],