summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2020-02-08 10:29:52 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2020-02-08 10:31:04 +0100
commit33fe1a61e10d23d5ffd3155ebddc4e9dd2834807 (patch)
treebe0a520f3328d55f2293543b7f24af32f1814be3 /media-radio
parentapp-text/enchant: remove old (diff)
downloadgentoo-33fe1a61e10d23d5ffd3155ebddc4e9dd2834807.tar.gz
gentoo-33fe1a61e10d23d5ffd3155ebddc4e9dd2834807.tar.bz2
gentoo-33fe1a61e10d23d5ffd3155ebddc4e9dd2834807.zip
media-radio/xdx: Fix building with -fno-common
Bump to EAPI=7 Closes: https://bugs.gentoo.org/708376 Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/xdx/files/xdx-2.5.0-fno-common.patch25
-rw-r--r--media-radio/xdx/xdx-2.5.0.ebuild9
2 files changed, 31 insertions, 3 deletions
diff --git a/media-radio/xdx/files/xdx-2.5.0-fno-common.patch b/media-radio/xdx/files/xdx-2.5.0-fno-common.patch
new file mode 100644
index 000000000000..a707d09b0a78
--- /dev/null
+++ b/media-radio/xdx/files/xdx-2.5.0-fno-common.patch
@@ -0,0 +1,25 @@
+diff --git a/src/gui.c b/src/gui.c
+index a3af442..5298c11 100644
+--- a/src/gui.c
++++ b/src/gui.c
+@@ -76,6 +76,7 @@ extern preferencestype preferences;
+ static void on_highcheck_toggled(GtkToggleButton *togglebutton, gpointer user_data);
+ static void on_soundcheck_toggled(GtkToggleButton *togglebutton, gpointer user_data);
+
++guitype *gui;
+
+ /**********************************MAIN WINDOW********************************/
+ guitype *
+diff --git a/src/gui.h b/src/gui.h
+index 77b442f..6ba406f 100644
+--- a/src/gui.h
++++ b/src/gui.h
+@@ -53,7 +53,7 @@ typedef struct guitype {
+ gchar *high8tagname;
+ } guitype;
+
+-guitype *gui;
++extern guitype *gui;
+
+ guitype *new_gui(void);
+ void create_mainwindow(void);
diff --git a/media-radio/xdx/xdx-2.5.0.ebuild b/media-radio/xdx/xdx-2.5.0.ebuild
index 92511501a99d..ed0eaf1b2f52 100644
--- a/media-radio/xdx/xdx-2.5.0.ebuild
+++ b/media-radio/xdx/xdx-2.5.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="7"
inherit eutils
@@ -19,13 +19,16 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
nls? ( sys-devel/gettext )"
+PATCHES=( "${FILESDIR}/"${P}-fno-common.patch )
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
src_configure() {
econf $(use_enable nls)
}
src_install() {
emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog NEWS README TODO
+ einstalldocs
}
pkg_postinst() {