summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-18 23:04:36 +0200
committerDavid Seifert <soap@gentoo.org>2021-06-18 23:04:36 +0200
commit474fdeace4c49b465a595b7bf7417159da405e54 (patch)
treeced964df6077fc8d612b02c0274a8be2ca02a3e4 /media-radio
parentgames-strategy/dopewars: add pkgconfig or pkgconfig-referenced libs deps (diff)
downloadgentoo-474fdeace4c49b465a595b7bf7417159da405e54.tar.gz
gentoo-474fdeace4c49b465a595b7bf7417159da405e54.tar.bz2
gentoo-474fdeace4c49b465a595b7bf7417159da405e54.zip
media-radio/fsync-mdc1200-decode: add pkgconfig or pkgconfig-referenced libs deps
Add dependencies for either virtual/pkgconfig, move it into BDEPEND where applicable, or add dependencies for libraries we're trying to find with pkgconfig. Package-Manager: Portage-3.0.18-prefix, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-1.0.ebuild2
-rw-r--r--media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-9999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-1.0.ebuild b/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-1.0.ebuild
index 2316114ab76b..050d3b649115 100644
--- a/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-1.0.ebuild
+++ b/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-1.0.ebuild
@@ -23,7 +23,7 @@ IUSE=""
DEPEND="media-sound/pulseaudio:="
RDEPEND="${DEPEND}"
-BDEPEND=""
+BDEPEND="virtual/pkgconfig"
src_compile() {
$(tc-getCC) -o fsync-mdc1200-decode ${CFLAGS} ${LDFLAGS} demod.c fsync_decode.c mdc_decode.c $($(tc-getPKG_CONFIG) --cflags --libs libpulse-simple)
diff --git a/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-9999.ebuild b/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-9999.ebuild
index 2316114ab76b..050d3b649115 100644
--- a/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-9999.ebuild
+++ b/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-9999.ebuild
@@ -23,7 +23,7 @@ IUSE=""
DEPEND="media-sound/pulseaudio:="
RDEPEND="${DEPEND}"
-BDEPEND=""
+BDEPEND="virtual/pkgconfig"
src_compile() {
$(tc-getCC) -o fsync-mdc1200-decode ${CFLAGS} ${LDFLAGS} demod.c fsync_decode.c mdc_decode.c $($(tc-getPKG_CONFIG) --cflags --libs libpulse-simple)