summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2017-04-15 18:32:39 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2017-04-15 18:32:39 +0200
commit6003c12d8f04d506853f1554360c78abdf201c21 (patch)
tree163a18f7db64bbfb09fec8b9128284162618020c /media-radio
parentkde-plasma/kwin: Drop 5.9.4 (r0) (diff)
downloadgentoo-6003c12d8f04d506853f1554360c78abdf201c21.tar.gz
gentoo-6003c12d8f04d506853f1554360c78abdf201c21.tar.bz2
gentoo-6003c12d8f04d506853f1554360c78abdf201c21.zip
media-radio/xwxapt: Version bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/xwxapt/Manifest1
-rw-r--r--media-radio/xwxapt/xwxapt-2.9.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/media-radio/xwxapt/Manifest b/media-radio/xwxapt/Manifest
index 5c625d8245f5..260e8b0708c5 100644
--- a/media-radio/xwxapt/Manifest
+++ b/media-radio/xwxapt/Manifest
@@ -1,2 +1,3 @@
DIST xwxapt-2.4.tar.bz2 149636 SHA256 82bc3d9423c8c76dff382f48747e3eaaa3fd6aea38c3bfb240c867df5102f2bf SHA512 61676dcb4bb57789fa86ef0fa9b70146f586353bc3bcd44939bcd85c6f160a56df3d09ddfbf66329677e73508eaeaa2c32493a266ef27e0f5156ce68993cafb8 WHIRLPOOL d99c58f53e1177bd03a5bd42e58a85eef94b5f47dc9dac8021d938d74aa395bec34191591628fc943b447ff58ff3fccc2df9ae03109e8681fc3a3c9723c481f8
DIST xwxapt-2.7.tar.bz2 168160 SHA256 fa28f867e9859dd5198a16e0005ccd10b637342a5cc81d66b804a6eef4d98c06 SHA512 591e471c79a67c80d756394068fb8fab14292460f771978dcbfada2501dde648eab5d30573dbfaa328f66f20a473aa504bbece0bc6dd5cf797087bed569f953c WHIRLPOOL 9b8e3b00386341ecac053c107cb036f02f9d9ed3e928759bf580c55b671b130b0f253011539582944e56878fbe6cea10b21b5a112777d1f6e765c48e7f6374e5
+DIST xwxapt-2.9.tar.bz2 170003 SHA256 cf67dd4f0f1d9ce6704f7abeb9e06ac59f47d2d2dff6632c02ebe195c97a6cce SHA512 7477d93dfe91bc09e6ff0d3e0736b0ca66c06e9fc8f9956660c54cf6e052ff10a98010223834eab0cb353cd498ee5bbd35aaca2e8517ec95fe4991058faf98c4 WHIRLPOOL 60a8f35fd3822c57e45b9bd67738c989d74190c27f63eadcd447c2a3b3ab08ca97e1d785bf3564c0cfc2b4e79f6ccc405e8c40f43e1e26df9a2f561d6643ac64
diff --git a/media-radio/xwxapt/xwxapt-2.9.ebuild b/media-radio/xwxapt/xwxapt-2.9.ebuild
new file mode 100644
index 000000000000..40f26ed1177c
--- /dev/null
+++ b/media-radio/xwxapt/xwxapt-2.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="GTK+ linux weather satellite APT image decoder software"
+HOMEPAGE="http://www.qsl.net/5b4az/pages/apt.html"
+SRC_URI="http://www.qsl.net/5b4az/pkg/apt/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ net-wireless/rtl-sdr
+ media-libs/alsa-lib
+ dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ # create missing mkinstalldir and prepare package
+ glib-gettextize --force --copy || die "gettextize failed"
+ eautoreconf
+}
+
+src_install() {
+ default
+ dohtml doc/xwxapt.html
+ insinto /usr/share/${PN}
+ doins xwxapt/xwxaptrc
+ dodir /usr/share/${PN}/images /usr/share/${PN}/records
+}
+
+pkg_postinst() {
+ einfo "You must copy the /usr/share/xwxapt directory into your home directory"
+ einfo "and configure the contained xwxaptrc file before starting the program"
+}