summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2022-02-07 19:43:00 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2022-02-07 19:43:00 +0100
commita2fe58bfad5cdf534d6ae3e3e6de3d48843509ed (patch)
tree6438e09965d0ac87b5cad1a8c813680c60950181 /media-radio
parentmedia-sound/puddletag: Version bump. (diff)
downloadgentoo-a2fe58bfad5cdf534d6ae3e3e6de3d48843509ed.tar.gz
gentoo-a2fe58bfad5cdf534d6ae3e3e6de3d48843509ed.tar.bz2
gentoo-a2fe58bfad5cdf534d6ae3e3e6de3d48843509ed.zip
media-radio/fldigi: Fixes musl build error
Closes: https://bugs.gentoo.org/832231 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/fldigi/files/fldigi-4.1.20-musl.patch14
-rw-r--r--media-radio/fldigi/fldigi-4.1.20.ebuild9
2 files changed, 22 insertions, 1 deletions
diff --git a/media-radio/fldigi/files/fldigi-4.1.20-musl.patch b/media-radio/fldigi/files/fldigi-4.1.20-musl.patch
new file mode 100644
index 000000000000..5b96abf40337
--- /dev/null
+++ b/media-radio/fldigi/files/fldigi-4.1.20-musl.patch
@@ -0,0 +1,14 @@
+diff --git a/src/cmedia/cmedia.cxx b/src/cmedia/cmedia.cxx
+index b08e3d7..cc775e9 100644
+--- a/src/cmedia/cmedia.cxx
++++ b/src/cmedia/cmedia.cxx
+@@ -41,9 +41,6 @@
+ #ifndef __WIN32__
+ #include <termios.h>
+ #include <glob.h>
+-# ifndef __APPLE__
+-# include <error.h>
+-# endif
+ #endif
+
+ #include "config.h"
diff --git a/media-radio/fldigi/fldigi-4.1.20.ebuild b/media-radio/fldigi/fldigi-4.1.20.ebuild
index 76084ffc4c43..792f85ce34c9 100644
--- a/media-radio/fldigi/fldigi-4.1.20.ebuild
+++ b/media-radio/fldigi/fldigi-4.1.20.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -35,6 +35,13 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS ChangeLog NEWS README )
+PATCHES=( "${FILESDIR}/${PN}-4.1.20-musl.patch" )
+
+src_prepare() {
+ eapply ${PATCHES[@]}
+ eapply_user
+}
+
src_configure() {
append-cxxflags $(test-flags-CXX -std=c++14)
local myconf=""