summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Linden <karl.j.linden@gmail.com>2017-05-09 08:07:54 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-09 09:26:10 +0200
commitb97076af34461886f7a86248bba665f60e340616 (patch)
tree5b9f7b1fde6a0931ce81be5dd7e3850f300440e6 /media-sound/a2jmidid/a2jmidid-8-r2.ebuild
parentnet-dns/bind-tools: Remove old versions (diff)
downloadgentoo-b97076af34461886f7a86248bba665f60e340616.tar.gz
gentoo-b97076af34461886f7a86248bba665f60e340616.tar.bz2
gentoo-b97076af34461886f7a86248bba665f60e340616.zip
media-sound/a2jmidid: depend on virtual/jack
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'media-sound/a2jmidid/a2jmidid-8-r2.ebuild')
-rw-r--r--media-sound/a2jmidid/a2jmidid-8-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-sound/a2jmidid/a2jmidid-8-r2.ebuild b/media-sound/a2jmidid/a2jmidid-8-r2.ebuild
new file mode 100644
index 000000000000..2175fa4b6917
--- /dev/null
+++ b/media-sound/a2jmidid/a2jmidid-8-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='threads(+)'
+NO_WAF_LIBDIR=1
+
+inherit python-single-r1 toolchain-funcs waf-utils eutils
+
+DESCRIPTION="Daemon for exposing legacy ALSA sequencer applications in JACK MIDI system"
+HOMEPAGE="http://home.gna.org/a2jmidid/"
+SRC_URI="http://download.gna.org/a2jmidid/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="dbus"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="media-libs/alsa-lib
+ virtual/jack
+ dbus? ( sys-apps/dbus )
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=(AUTHORS README NEWS internals.txt)
+
+src_prepare() {
+ # Bug 518382
+ epatch "${FILESDIR}"/${PN}-link.patch
+}
+
+src_configure() {
+ if use dbus ; then
+ waf-utils_src_configure
+ else
+ waf-utils_src_configure --disable-dbus
+ fi
+}
+
+src_install() {
+ waf-utils_src_install
+ python_fix_shebang "${ED}"
+}