summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-25 16:58:19 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-25 17:06:22 +0200
commitd1ebc68d7655c5dff28da92a795e7e37bfe664b9 (patch)
treef330de671e1d25f5e89619360ca61e3ba061fea9 /media-sound/abcm2ps/abcm2ps-8.13.10.ebuild
parentmedia-sound/abcm2ps: remove old (diff)
downloadgentoo-d1ebc68d7655c5dff28da92a795e7e37bfe664b9.tar.gz
gentoo-d1ebc68d7655c5dff28da92a795e7e37bfe664b9.tar.bz2
gentoo-d1ebc68d7655c5dff28da92a795e7e37bfe664b9.zip
media-sound/abcm2ps: Bump to 8.13.10
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'media-sound/abcm2ps/abcm2ps-8.13.10.ebuild')
-rw-r--r--media-sound/abcm2ps/abcm2ps-8.13.10.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-sound/abcm2ps/abcm2ps-8.13.10.ebuild b/media-sound/abcm2ps/abcm2ps-8.13.10.ebuild
new file mode 100644
index 000000000000..2d4a35b58897
--- /dev/null
+++ b/media-sound/abcm2ps/abcm2ps-8.13.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="A program to convert abc files to Postscript files"
+HOMEPAGE="http://moinejf.free.fr/"
+SRC_URI="http://moinejf.free.fr/${P}.tar.gz
+ http://moinejf.free.fr/transpose_abc.pl"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples pango"
+
+RDEPEND="pango? ( x11-libs/pango media-libs/freetype:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --enable-a4 \
+ --enable-deco-is-roll \
+ $(use_enable pango)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin abcm2ps
+
+ insinto /usr/share/${PN}
+ doins *.fmt
+
+ dodoc Changes README *.txt
+
+ if use examples ; then
+ docinto examples
+ dodoc *.{abc,eps}
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ docinto contrib
+ dodoc "${DISTDIR}"/transpose_abc.pl
+}