summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-07-31 21:12:05 -0600
committerTim Harder <radhermit@gentoo.org>2019-07-31 21:13:05 -0600
commitc334c3614e8752117f2f6060f9d4590e610c83e7 (patch)
tree87160ee96ab473c49315d1013dfd38d38eb91862 /media-sound/abcmidi/abcmidi-2019.07.12.ebuild
parentsci-libs/{blis,mkl-rt}: Add Gentoo Science Project as maintainer. (diff)
downloadgentoo-c334c3614e8752117f2f6060f9d4590e610c83e7.tar.gz
gentoo-c334c3614e8752117f2f6060f9d4590e610c83e7.tar.bz2
gentoo-c334c3614e8752117f2f6060f9d4590e610c83e7.zip
media-sound/abcmidi: version bump to 2019.07.12
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'media-sound/abcmidi/abcmidi-2019.07.12.ebuild')
-rw-r--r--media-sound/abcmidi/abcmidi-2019.07.12.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/abcmidi/abcmidi-2019.07.12.ebuild b/media-sound/abcmidi/abcmidi-2019.07.12.ebuild
new file mode 100644
index 000000000000..ce075821d84d
--- /dev/null
+++ b/media-sound/abcmidi/abcmidi-2019.07.12.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P="abcMIDI-${PV}"
+DESCRIPTION="Programs for processing ABC music notation files"
+HOMEPAGE="https://ifdo.ca/~seymour/runabc/top.html"
+SRC_URI="https://ifdo.ca/~seymour/runabc/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ local PATCHES=( "${FILESDIR}"/${PN}-2016.05.05-docs.patch )
+ default
+
+ rm configure Makefile || die
+ sed -i "s:-O2::" configure.ac || die
+
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc doc/{AUTHORS,CHANGES,abcguide.txt,abcmatch.txt,history.txt,readme.txt,yapshelp.txt}
+
+ if use examples ; then
+ docinto examples
+ dodoc samples/*.abc
+ fi
+}