summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/abcmidi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/abcmidi')
-rw-r--r--media-sound/abcmidi/Manifest2
-rw-r--r--media-sound/abcmidi/abcmidi-2014.12.25.ebuild38
-rw-r--r--media-sound/abcmidi/abcmidi-2015.02.22.ebuild38
-rw-r--r--media-sound/abcmidi/files/abcmidi-2011.10.19-install.patch24
-rw-r--r--media-sound/abcmidi/metadata.xml5
5 files changed, 107 insertions, 0 deletions
diff --git a/media-sound/abcmidi/Manifest b/media-sound/abcmidi/Manifest
new file mode 100644
index 000000000000..09290d354e6b
--- /dev/null
+++ b/media-sound/abcmidi/Manifest
@@ -0,0 +1,2 @@
+DIST abcMIDI-2014-12-25.zip 515102 SHA256 eb58236eb80c4b454c16c7df36ebb38712f60074ebbd0cc5cc992fb2ff6bc3cc SHA512 3801a35c23d3bc145c50d652f61c2ffd245cb78d080836985dd6f495d37a31742b2bfd372c7d8ccf12d75fd2d7ccd70a119eb03f2f7abdc45ff666b26d535968 WHIRLPOOL 94f15fc6689da6f7b91b9601bf329b86bc5024ca1e24b8fd6189917390715c701d75cbaa529430cb5a295703d2f2b74393336f5e20365d446c7027e417e6e562
+DIST abcMIDI-2015-02-22.zip 515257 SHA256 56576371a551f7a83d5eb60578fb0af4b17e55c27ebbd78431b8919b7259fb60 SHA512 a9b686dcbcbc63e5ca2284bf4a355718aeca12853b3b0a01a578bfd2b9e2c1c4ede5a7a33c413882e9e0254349591a82a7e13bfb2e1c4e9b2b967fcb089376e2 WHIRLPOOL 15661abcd8fbef72d3e04af3181251575def6d5942fbd38c0a133e95d82af1f903ef2b03b302c0dc7c1a9703243c9a96470dff459f87c2f2a1446b37c869559b
diff --git a/media-sound/abcmidi/abcmidi-2014.12.25.ebuild b/media-sound/abcmidi/abcmidi-2014.12.25.ebuild
new file mode 100644
index 000000000000..323b7f398e69
--- /dev/null
+++ b/media-sound/abcmidi/abcmidi-2014.12.25.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils versionator autotools
+
+MY_P="abcMIDI-$(replace_all_version_separators '-')"
+DESCRIPTION="Programs for processing ABC music notation files"
+HOMEPAGE="http://abc.sourceforge.net/abcMIDI/"
+SRC_URI="http://ifdo.pugmarks.com/~seymour/runabc/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2011.10.19-install.patch
+ rm configure makefile || die
+ sed -i "s:-O2::" configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc doc/{AUTHORS,CHANGES,abcguide.txt,abcmatch.txt,history.txt,readme.txt,yapshelp.txt}
+
+ if use examples ; then
+ docinto examples
+ dodoc samples/*.abc
+ fi
+}
diff --git a/media-sound/abcmidi/abcmidi-2015.02.22.ebuild b/media-sound/abcmidi/abcmidi-2015.02.22.ebuild
new file mode 100644
index 000000000000..323b7f398e69
--- /dev/null
+++ b/media-sound/abcmidi/abcmidi-2015.02.22.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils versionator autotools
+
+MY_P="abcMIDI-$(replace_all_version_separators '-')"
+DESCRIPTION="Programs for processing ABC music notation files"
+HOMEPAGE="http://abc.sourceforge.net/abcMIDI/"
+SRC_URI="http://ifdo.pugmarks.com/~seymour/runabc/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2011.10.19-install.patch
+ rm configure makefile || die
+ sed -i "s:-O2::" configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc doc/{AUTHORS,CHANGES,abcguide.txt,abcmatch.txt,history.txt,readme.txt,yapshelp.txt}
+
+ if use examples ; then
+ docinto examples
+ dodoc samples/*.abc
+ fi
+}
diff --git a/media-sound/abcmidi/files/abcmidi-2011.10.19-install.patch b/media-sound/abcmidi/files/abcmidi-2011.10.19-install.patch
new file mode 100644
index 000000000000..5fa8ca2a5112
--- /dev/null
+++ b/media-sound/abcmidi/files/abcmidi-2011.10.19-install.patch
@@ -0,0 +1,24 @@
+--- abcmidi/Makefile.in.orig
++++ abcmidi/Makefile.in
+@@ -140,17 +140,10 @@
+ rm *.o ${binaries}
+
+ install: abc2midi midi2abc abc2abc mftext midicopy yaps abcmatch
+- test -d $(DESTDIR)${prefix}/${bindir} || mkdir -p $(DESTDIR)${prefix}/${bindir}
+- $(INSTALL) -m 755 ${binaries} $(DESTDIR)${prefix}/${bindir}
+-
+- # install documentation
+- test -d $(DESTDIR)${PREFIX}/share/doc/abcmidi || mkdir -p $(DESTDIR)${prefix}/${docdir}
+- $(INSTALL) -m 644 doc/*.txt $(DESTDIR)${prefix}/${docdir}
+- $(INSTALL) -m 644 doc/AUTHORS $(DESTDIR)${prefix}/${docdir}
+- $(INSTALL) -m 644 doc/CHANGES $(DESTDIR)${prefix}/${docdir}
+- $(INSTALL) -m 644 VERSION $(DESTDIR)${prefix}/${docdir}
++ test -d $(DESTDIR)${bindir} || mkdir -p $(DESTDIR)${bindir}
++ $(INSTALL) -m 755 ${binaries} $(DESTDIR)${bindir}
+
+ # install manpages
+- test -d $(DESTDIR)${prefix}/${mandir} || mkdir -p $(DESTDIR)${prefix}/${mandir};
+- $(INSTALL) -m 644 doc/*.1 $(DESTDIR)${prefix}/${mandir}
++ test -d $(DESTDIR)${mandir} || mkdir -p $(DESTDIR)${mandir}
++ $(INSTALL) -m 644 doc/*.1 $(DESTDIR)${mandir}
+
diff --git a/media-sound/abcmidi/metadata.xml b/media-sound/abcmidi/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/abcmidi/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>