summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-12-22 11:36:30 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-12-22 11:51:17 +0100
commit91fcfc65788e40eb7b7cde7fafb98def676fdda4 (patch)
tree1d8a72e21a28580cbc4f9c8603874f2e33e12769 /media-sound/alsa-utils
parentmedia-libs/alsa-lib: Bump to version 1.1.3 (diff)
downloadgentoo-91fcfc65788e40eb7b7cde7fafb98def676fdda4.tar.gz
gentoo-91fcfc65788e40eb7b7cde7fafb98def676fdda4.tar.bz2
gentoo-91fcfc65788e40eb7b7cde7fafb98def676fdda4.zip
media-sound/alsa-utils: Bump to version 1.1.3
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-sound/alsa-utils')
-rw-r--r--media-sound/alsa-utils/Manifest1
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.1.3.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/media-sound/alsa-utils/Manifest b/media-sound/alsa-utils/Manifest
index 9dfa5054c2eb..a184307f5e53 100644
--- a/media-sound/alsa-utils/Manifest
+++ b/media-sound/alsa-utils/Manifest
@@ -1,3 +1,4 @@
DIST alsa-utils-1.0.29.tar.bz2 1154497 SHA256 5160058f3e14483ced5de919dd473f93932059454530a9b7ef97dcabd6833e9b SHA512 0d83805aa7b1c975524cc5ecd4aa6eb36126bc434458f9e9475e4bd1b14bbb4bf9691096ca7973342a3798e97a361451c078f4595f8f4275db64d6b443ca5928 WHIRLPOOL ccad5115148045e0c5f139d70306e801e250aa3946f60d9cd0a47c84c72f6d8689e53105030589309c98ddd4a7b871bb8dc03f00fcc3d46cc3e08c4718299407
DIST alsa-utils-1.1.1.tar.bz2 1186408 SHA256 89757c9abaf420831b088fce354d492acc170bd02bb50eb7392c175f594b8041 SHA512 3af1e43cb2eab7e5119d83036ab6f4eeb106b66b4a57122cc8df243b6dbda90d39a0290a2af3a904b4929e2d90e8fcded9eda2a38bae1fd8e371a6d7a043376e WHIRLPOOL ea7daaf4055469dd5cb128abbe9a986e2b99b27c59d964041a92e82667e520adadb1e87d38bfa83d5b8ffbc382d7d9401c9d4887ca19546e4d1f34ba1cf7d705
DIST alsa-utils-1.1.2.tar.bz2 1193140 SHA256 7af603c0877d1251599d65b4fbc372e63a54371b888f5c26c6a86ac1d0519071 SHA512 38dc3331e8410123085738e74ca34c860666027ee2f6aaa21f48e726c84d8e6264043c8c7111ce2b1e158a0f38142a04d72a128ee54e00173dc4e4ba514d2f14 WHIRLPOOL 353d636271fd4354e7a7b986c08a3eabdb91bb8239b3d14a2163dea095dee010cd777276901c11df58a4fcba24680770512df4784e446a63941224f9ee79f632
+DIST alsa-utils-1.1.3.tar.bz2 1201424 SHA256 127217a54eea0f9a49700a2f239a2d4f5384aa094d68df04a8eb80132eb6167c SHA512 a0a00578e7f7ed8441628757048412813a0345f0a3f2e085cda7a881ae3c6e22f7cf1e5119f8200e2e4340e42152b91aa5bdc20646b8422adc74ba00e4c59363 WHIRLPOOL 10f1f8f5b7a659dc7ba79c934076eafbbd72f4892b571660a6224fc1061b4e893e2f5a937187a4eb50f2e982c07e097c965a88052451218adcde2e5cd3bfb6f9
diff --git a/media-sound/alsa-utils/alsa-utils-1.1.3.ebuild b/media-sound/alsa-utils/alsa-utils-1.1.3.ebuild
new file mode 100644
index 000000000000..9bd9df90abe6
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.1.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils systemd udev
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="bat doc +libsamplerate +ncurses nls selinux"
+
+CDEPEND=">=media-libs/alsa-lib-${PV}
+ libsamplerate? ( media-libs/libsamplerate )
+ ncurses? ( >=sys-libs/ncurses-5.7-r7:0= )
+ bat? ( sci-libs/fftw:= )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? ( app-text/xmlto )"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-alsa )"
+
+src_configure() {
+ local myconf
+ use doc || myconf='--disable-xmlto'
+
+ # --disable-alsaconf because it doesn't work with sys-apps/kmod wrt #456214
+ econf \
+ --disable-maintainer-mode \
+ $(use_enable bat) \
+ $(use_enable libsamplerate alsaloop) \
+ $(use_enable nls) \
+ $(use_enable ncurses alsamixer) \
+ --disable-alsaconf \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ --with-udev-rules-dir="$(get_udevdir)"/rules.d \
+ ${myconf}
+}
+
+src_install() {
+ default
+ dodoc seq/*/README.*
+
+ newinitd "${FILESDIR}"/alsasound.initd-r6 alsasound
+ newconfd "${FILESDIR}"/alsasound.confd-r4 alsasound
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/alsa-modules.conf-rc alsa.conf
+
+ keepdir /var/lib/alsa
+
+ # ALSA lib parser.c:1266:(uc_mgr_scan_master_configs) error: could not
+ # scan directory /usr/share/alsa/ucm: No such file or directory
+ # alsaucm: unable to obtain card list: No such file or directory
+ keepdir /usr/share/alsa/ucm
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "To take advantage of the init script, and automate the process of"
+ elog "saving and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog "# rc-update add alsasound boot"
+ ewarn
+ ewarn "The ALSA core should be built into the kernel or loaded through other"
+ ewarn "means. There is no longer any modular auto(un)loading in alsa-utils."
+ fi
+}