summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLarry Pyeatt <larry.pyeatt@sdsmt.edu>2020-12-23 09:31:05 -0700
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-26 23:16:59 +0100
commitecd2764588b988e6a82ca122296ded6158bcc412 (patch)
tree832a0215b3bafb833338a101209758cc3c10d35c /media-sound/alsamixergui
parentmedia-libs/cimg: Security cleanup (diff)
downloadgentoo-ecd2764588b988e6a82ca122296ded6158bcc412.tar.gz
gentoo-ecd2764588b988e6a82ca122296ded6158bcc412.tar.bz2
gentoo-ecd2764588b988e6a82ca122296ded6158bcc412.zip
media-sound/alsamixergui: strsignal patch for bug #738176
Closes: https://bugs.gentoo.org/738176 Suggested-by: Larry Pyeatt <larry.pyeatt@sdsmt.edu> Signed-off-by: Larry Pyeatt <larry.pyeatt@sdsmt.edu> Closes: https://github.com/gentoo/gentoo/pull/18786 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/alsamixergui')
-rw-r--r--media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r4.ebuild1
-rw-r--r--media-sound/alsamixergui/files/alsamixergui-0.9.0.1.2-strsignal.patch13
2 files changed, 14 insertions, 0 deletions
diff --git a/media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r4.ebuild b/media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r4.ebuild
index 16bb940cc173..1144c94e53b2 100644
--- a/media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r4.ebuild
+++ b/media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r4.ebuild
@@ -27,6 +27,7 @@ PATCHES=(
"${FILESDIR}"/${P}-gcc34.patch
"${FILESDIR}"/segfault-on-exit.patch
"${FILESDIR}"/${P}-fltk-1.1.patch
+ "${FILESDIR}"/${P}-strsignal.patch
)
src_prepare() {
diff --git a/media-sound/alsamixergui/files/alsamixergui-0.9.0.1.2-strsignal.patch b/media-sound/alsamixergui/files/alsamixergui-0.9.0.1.2-strsignal.patch
new file mode 100644
index 000000000000..cd72309f9a0e
--- /dev/null
+++ b/media-sound/alsamixergui/files/alsamixergui-0.9.0.1.2-strsignal.patch
@@ -0,0 +1,13 @@
+diff --git a/src/alsamixer.cxx b/src/alsamixer.cxx
+index c7fda51..0d17e21 100644
+--- a/src/alsamixer.cxx
++++ b/src/alsamixer.cxx
+@@ -2081,7 +2081,7 @@ static void
+ mixer_signal_handler (int signal)
+ {
+ if (signal != SIGSEGV)
+- mixer_abort (ERR_SIGNAL, sys_siglist[signal], 0);
++ mixer_abort (ERR_SIGNAL, strsignal(signal), 0);
+ else
+ {
+ fprintf (stderr, "\nSegmentation fault.\n");