summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-04-27 19:49:51 +0200
committerJohannes Huber <johu@gentoo.org>2016-04-27 19:50:03 +0200
commit97782e5e71bcbba3bd8d0be9566c569613046bfc (patch)
treeadc396214c71c35eaab6370217747ab5a9caffc8 /media-sound/amarok/files
parentgames-fps/warsow-community-map-pack: Initial commit with ebuild and update by... (diff)
downloadgentoo-97782e5e71bcbba3bd8d0be9566c569613046bfc.tar.gz
gentoo-97782e5e71bcbba3bd8d0be9566c569613046bfc.tar.bz2
gentoo-97782e5e71bcbba3bd8d0be9566c569613046bfc.zip
media-sound/amarok: Version bump 2.8.90 (2.9 beta)
Package-Manager: portage-2.2.28
Diffstat (limited to 'media-sound/amarok/files')
-rw-r--r--media-sound/amarok/files/amarok-2.8.90-mysql-embedded.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/amarok/files/amarok-2.8.90-mysql-embedded.patch b/media-sound/amarok/files/amarok-2.8.90-mysql-embedded.patch
new file mode 100644
index 000000000000..b03aa1897cc4
--- /dev/null
+++ b/media-sound/amarok/files/amarok-2.8.90-mysql-embedded.patch
@@ -0,0 +1,34 @@
+From 048ca3d57228759f05af7b9553200fd362aeaa8b Mon Sep 17 00:00:00 2001
+From: Matt Whitlock <kde@mattwhitlock.name>
+Date: Tue, 29 Mar 2016 12:22:41 -0400
+Subject: [PATCH] Only link with MYSQL_EMBEDDED_LIBRARIES if
+ WITH_MYSQL_EMBEDDED
+
+REVIEW: 127523
+---
+ src/core-impl/collections/db/sql/mysqlcollection/CMakeLists.txt | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/src/core-impl/collections/db/sql/mysqlcollection/CMakeLists.txt b/src/core-impl/collections/db/sql/mysqlcollection/CMakeLists.txt
+index 244cde1..4c618fc 100644
+--- a/src/core-impl/collections/db/sql/mysqlcollection/CMakeLists.txt
++++ b/src/core-impl/collections/db/sql/mysqlcollection/CMakeLists.txt
+@@ -21,11 +21,14 @@ target_link_libraries(amarok_collection-mysqlcollection
+ ${KDE4_KDECORE_LIBS}
+ ${QT_QTCORE_LIBRARY}
+ ${QT_QTGUI_LIBRARY}
+- ${MYSQL_EMBEDDED_LIBRARIES}
+ ${CMAKE_DL_LIBS}
+ ${ZLIB_LIBRARIES}
+ )
+
++if(WITH_MYSQL_EMBEDDED)
++ target_link_libraries( amarok_collection-mysqlcollection ${MYSQL_EMBEDDED_LIBRARIES} )
++endif(WITH_MYSQL_EMBEDDED)
++
+ if(NOT WIN32 AND NOT APPLE)
+ target_link_libraries( amarok_collection-mysqlcollection crypt pthread )
+ endif(NOT WIN32 AND NOT APPLE)
+--
+2.8.1
+