summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/apulse
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/apulse')
-rw-r--r--media-sound/apulse/Manifest2
-rw-r--r--media-sound/apulse/apulse-0.1.4.ebuild28
-rw-r--r--media-sound/apulse/apulse-0.1.6.ebuild28
-rw-r--r--media-sound/apulse/metadata.xml11
4 files changed, 69 insertions, 0 deletions
diff --git a/media-sound/apulse/Manifest b/media-sound/apulse/Manifest
new file mode 100644
index 000000000000..c1d978bce1b1
--- /dev/null
+++ b/media-sound/apulse/Manifest
@@ -0,0 +1,2 @@
+DIST apulse-0.1.4.tar.gz 99976 SHA256 717bc537c389af546b4db2ed7622a8896f7f0f306612c9eb6c693a70c104c86f SHA512 500abca0f6b4df35acb417744a5967e58ceff8cc2a0d640db03847d79b077295abe8888ee5d0008383349bd964345a340334f39e1f55286713db94a86c6596dc WHIRLPOOL 7fe604ed3128cb24d375f4f84ee77317fd499202d8bf46f9c68735501b35a55050852d08260b2c4ad0419ac32a3d330946c65aa402b9b66dbf6d25c3a92966bb
+DIST apulse-0.1.6.tar.gz 101938 SHA256 f9ffbf7aff96680beff3243758e5c1e0d4ac9043d4bd6cbfb219890b4b91c9f3 SHA512 0bcc3966a1455bac64e7b9731a988c5d10d893544354453b70f36121e92854a632f33a2ec84fa2ee4d2010221f82fb83cea872d66c4b053b0cd9014215014dc2 WHIRLPOOL 114d7e5d2f344ee4bdb96df01db8f10b10798ef2b332542f45e0e2957462c8255963a7d00628c01fcf58c19703c207aa967fdb258efcd28922ef05687517a8d3
diff --git a/media-sound/apulse/apulse-0.1.4.ebuild b/media-sound/apulse/apulse-0.1.4.ebuild
new file mode 100644
index 000000000000..e3d67682ac95
--- /dev/null
+++ b/media-sound/apulse/apulse-0.1.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-multilib
+
+DESCRIPTION="PulseAudio emulation for ALSA"
+HOMEPAGE="https://github.com/i-rinat/apulse"
+SRC_URI="https://github.com/i-rinat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/glib:2[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]"
+RDEPEND="${DEPEND}
+ !!media-plugins/alsa-plugins[pulseaudio]"
+
+MULTILIB_CHOST_TOOLS=( /usr/bin/apulse )
+
+multilib_src_configure() {
+ local mycmakeargs="-DAPULSEPATH=${EPREFIX}/usr/$(get_libdir)/apulse"
+
+ cmake-utils_src_configure
+}
diff --git a/media-sound/apulse/apulse-0.1.6.ebuild b/media-sound/apulse/apulse-0.1.6.ebuild
new file mode 100644
index 000000000000..e3d67682ac95
--- /dev/null
+++ b/media-sound/apulse/apulse-0.1.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-multilib
+
+DESCRIPTION="PulseAudio emulation for ALSA"
+HOMEPAGE="https://github.com/i-rinat/apulse"
+SRC_URI="https://github.com/i-rinat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/glib:2[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]"
+RDEPEND="${DEPEND}
+ !!media-plugins/alsa-plugins[pulseaudio]"
+
+MULTILIB_CHOST_TOOLS=( /usr/bin/apulse )
+
+multilib_src_configure() {
+ local mycmakeargs="-DAPULSEPATH=${EPREFIX}/usr/$(get_libdir)/apulse"
+
+ cmake-utils_src_configure
+}
diff --git a/media-sound/apulse/metadata.xml b/media-sound/apulse/metadata.xml
new file mode 100644
index 000000000000..5673854e101f
--- /dev/null
+++ b/media-sound/apulse/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zlg@gentoo.org</email>
+ <name>Daniel Campbell</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">i-rinat/apulse</remote-id>
+ </upstream>
+</pkgmetadata>