summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/ardour/ardour-3.5.308-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/ardour/ardour-3.5.308-r1.ebuild')
-rw-r--r--media-sound/ardour/ardour-3.5.308-r1.ebuild121
1 files changed, 121 insertions, 0 deletions
diff --git a/media-sound/ardour/ardour-3.5.308-r1.ebuild b/media-sound/ardour/ardour-3.5.308-r1.ebuild
new file mode 100644
index 000000000000..9114305ad7b9
--- /dev/null
+++ b/media-sound/ardour/ardour-3.5.308-r1.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit eutils toolchain-funcs flag-o-matic python-any-r1 waf-utils
+
+DESCRIPTION="Digital Audio Workstation"
+HOMEPAGE="http://ardour.org/"
+
+if [ ${PV} = 9999 ]; then
+ KEYWORDS=""
+ EGIT_REPO_URI="http://git.ardour.org/ardour/ardour.git"
+ inherit git-2
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/Ardour/ardour/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="GPL-2"
+SLOT="3"
+IUSE="altivec debug doc nls lv2 cpu_flags_x86_sse"
+
+RDEPEND="media-libs/aubio
+ media-libs/liblo
+ sci-libs/fftw:3.0
+ media-libs/freetype:2
+ >=dev-libs/glib-2.10.1:2
+ dev-cpp/glibmm:2
+ >=x11-libs/gtk+-2.8.1:2
+ >=dev-libs/libxml2-2.6:2
+ >=media-libs/libsndfile-1.0.18
+ >=media-libs/libsamplerate-0.1
+ >=media-libs/rubberband-1.6.0
+ >=media-libs/libsoundtouch-1.6.0
+ media-libs/flac
+ media-libs/raptor:2
+ >=media-libs/liblrdf-0.4.0-r20
+ >=media-sound/jack-audio-connection-kit-0.120
+ >=gnome-base/libgnomecanvas-2
+ media-libs/vamp-plugin-sdk
+ dev-libs/libxslt
+ dev-libs/libsigc++:2
+ >=dev-cpp/gtkmm-2.16:2.4
+ >=dev-cpp/libgnomecanvasmm-2.26:2.6
+ media-libs/alsa-lib
+ x11-libs/pango
+ x11-libs/cairo
+ media-libs/libart_lgpl
+ virtual/libusb:0
+ dev-libs/boost
+ >=media-libs/taglib-1.7
+ net-misc/curl
+ lv2? (
+ >=media-libs/slv2-0.6.1
+ media-libs/lilv
+ media-libs/sratom
+ dev-libs/sord
+ >=media-libs/suil-0.6.10
+ >=media-libs/lv2-1.4.0
+ )"
+
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ doc? ( app-doc/doxygen[dot] )"
+ if ! [ ${PV} = 9999 ]; then
+ DEPEND="${DEPEND}"
+ fi
+
+src_unpack() {
+ if [ ${PV} = 9999 ]; then
+ git-2_src_unpack
+ else
+ unpack ${A}
+ fi
+}
+
+src_prepare(){
+ if ! [ ${PV} = 9999 ]; then
+ PVTEMP=`echo "${PV}" | sed "s/\./-/2"`
+ sed -e '/cmd = "git describe HEAD/,/utf-8/{s:cmd = \"git describe HEAD\":rev = \"'${PVTEMP}-gentoo'\":p;d}' -i "${S}"/wscript
+ sed -e 's/'os.getcwd\(\),\ \'.git'/'os.getcwd\(\),\ \'libs/'' -i "${S}"/wscript
+ sed -e 's/'os.path.exists\(\'.git'/'os.path.exists\(\'wscript/'' -i "${S}"/wscript
+
+ fi
+ epatch "${FILESDIR}"/${PN}-3.5.7-syslibs.patch
+ sed 's/'FLAGS\'\,\ optimization_flags'/'FLAGS\'\,\ \'\''/g' -i "${S}"/wscript
+}
+
+src_configure() {
+ tc-export CC CXX
+ mkdir -p "${D}"
+ waf-utils_src_configure \
+ --destdir="${D}" \
+ --prefix=/usr \
+ --configdir=/etc \
+ $(use lv2 && echo "--lv2" || echo "--no-lv2") \
+ $(use nls && echo "--nls" || echo "--no-nls") \
+ $(use debug && echo "--stl-debug" || echo "--optimize") \
+ $((use altivec || use cpu_flags_x86_sse) && echo "--fpu-optimization" || echo "--no-fpu-optimization") \
+ $(use doc && echo "--docs")
+}
+
+src_install() {
+ waf-utils_src_install
+ mv ${PN}.1 ${PN}${SLOT}.1
+ doman ${PN}${SLOT}.1
+ newicon icons/icon/ardour_icon_mac.png ${PN}${SLOT}.png
+ make_desktop_entry ardour3 ardour3 ardour3 AudioVideo
+}
+
+pkg_postinst() {
+ elog "If you are using Ardour and want to keep its development alive"
+ elog "then please consider to do a donation upstream at ardour.org. Thanks!"
+}