summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-17 15:15:50 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-17 15:16:35 +0200
commit5c43afe6861275a05aeb4d6b6e45cdbbccfef21b (patch)
treef10f0787ad65efb77f739e84a595a19ba6c01da3 /media-sound/audacity
parentapp-text/gspell: fix typo in REQUIRED_USE (diff)
downloadgentoo-5c43afe6861275a05aeb4d6b6e45cdbbccfef21b.tar.gz
gentoo-5c43afe6861275a05aeb4d6b6e45cdbbccfef21b.tar.bz2
gentoo-5c43afe6861275a05aeb4d6b6e45cdbbccfef21b.zip
media-sound/audacity: Allow for compiling with GCC 6
Gentoo-bug: 592448 * Patch by OpenSUSE Package-Manager: portage-2.3.0
Diffstat (limited to 'media-sound/audacity')
-rw-r--r--media-sound/audacity/audacity-2.1.2.ebuild7
-rw-r--r--media-sound/audacity/files/audacity-2.1.2-fix-c++14.patch41
2 files changed, 44 insertions, 4 deletions
diff --git a/media-sound/audacity/audacity-2.1.2.ebuild b/media-sound/audacity/audacity-2.1.2.ebuild
index 0a0dd61533eb..4331f0c4b5ef 100644
--- a/media-sound/audacity/audacity-2.1.2.ebuild
+++ b/media-sound/audacity/audacity-2.1.2.ebuild
@@ -49,10 +49,9 @@ REQUIRED_USE="soundtouch? ( midi )"
S=${WORKDIR}/${MY_P}
-#src_prepare() {
-# epatch "${FILESDIR}"/${P}-automagic.patch
-# AT_M4DIR="${S}/m4" eautoreconf
-#}
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.1.2-fix-c++14.patch"
+}
src_configure() {
WX_GTK_VER="3.0"
diff --git a/media-sound/audacity/files/audacity-2.1.2-fix-c++14.patch b/media-sound/audacity/files/audacity-2.1.2-fix-c++14.patch
new file mode 100644
index 000000000000..32bcf42fd8a0
--- /dev/null
+++ b/media-sound/audacity/files/audacity-2.1.2-fix-c++14.patch
@@ -0,0 +1,41 @@
+Fix building with C++14, which errors out due to bool -> T* conversions
+See also: https://bugs.gentoo.org/show_bug.cgi?id=592448
+
+Patch by OpenSUSE
+
+Index: src/effects/vamp/LoadVamp.cpp
+===================================================================
+--- src/effects/vamp/LoadVamp.cpp.orig
++++ src/effects/vamp/LoadVamp.cpp
+@@ -266,7 +266,7 @@ Plugin *VampEffectsModule::FindPlugin(co
+ Plugin *vp = PluginLoader::getInstance()->loadPlugin(key, 48000); // rate doesn't matter here
+ if (!vp)
+ {
+- return false;
++ return NULL;
+ }
+
+ // We limit the listed plugin outputs to those whose results can
+Index: src/import/ImportFLAC.cpp
+===================================================================
+--- src/import/ImportFLAC.cpp.orig
++++ src/import/ImportFLAC.cpp
+@@ -296,7 +296,7 @@ ImportFileHandle *FLACImportPlugin::Open
+ int cnt;
+ wxFile binaryFile;
+ if (!binaryFile.Open(filename)) {
+- return false; // File not found
++ return NULL; // File not found
+ }
+
+ #ifdef USE_LIBID3TAG
+@@ -313,7 +313,7 @@ ImportFileHandle *FLACImportPlugin::Open
+
+ if (cnt == wxInvalidOffset || strncmp(buf, FLAC_HEADER, 4) != 0) {
+ // File is not a FLAC file
+- return false;
++ return NULL;
+ }
+
+ // Open the file for import
+