summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-07-02 13:28:07 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-07-02 13:28:22 +0200
commit6d06f1f17739c5d5b3d5f23a9f1339ffc1f8afef (patch)
tree793747bda5b4966ba28234ca67cf2f4020f51614 /media-sound/bluez-alsa
parentnet-analyzer/netperf: Old. (diff)
downloadgentoo-6d06f1f17739c5d5b3d5f23a9f1339ffc1f8afef.tar.gz
gentoo-6d06f1f17739c5d5b3d5f23a9f1339ffc1f8afef.tar.bz2
gentoo-6d06f1f17739c5d5b3d5f23a9f1339ffc1f8afef.zip
media-sound/bluez-alsa: Sync with upstream changes.
Thanks-to: Arkadiusz Bokowy Closes: https://bugs.gentoo.org/659838 Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'media-sound/bluez-alsa')
-rw-r--r--media-sound/bluez-alsa/bluez-alsa-9999.ebuild20
-rw-r--r--media-sound/bluez-alsa/files/bluealsa-conf.d-24
2 files changed, 14 insertions, 10 deletions
diff --git a/media-sound/bluez-alsa/bluez-alsa-9999.ebuild b/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
index 8b3787db68d9..186e2b9681cb 100644
--- a/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
+++ b/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools eutils multilib-minimal
+EAPI=7
+inherit autotools multilib-minimal
DESCRIPTION="Bluetooth Audio ALSA Backend"
HOMEPAGE="https://github.com/Arkq/bluez-alsa"
@@ -29,7 +29,6 @@ RDEPEND=">=dev-libs/glib-2.16[dbus,${MULTILIB_USEDEP}]
sys-libs/ncurses:0=
)"
DEPEND="${RDEPEND}
- net-libs/ortp
virtual/pkgconfig"
src_prepare() {
@@ -38,19 +37,20 @@ src_prepare() {
}
multilib_src_configure() {
- ECONF_SOURCE="${S}" \
- econf \
- $(use_enable aac) \
- $(use_enable debug) \
+ local myeconfargs=(
+ $(use_enable aac)
+ $(use_enable debug)
$(multilib_native_use_enable hcitop)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_install_all() {
default
- prune_libtool_files --modules
+ find "${ED}" -name "*.la" -delete || die
newinitd "${FILESDIR}"/bluealsa-init.d bluealsa
- newconfd "${FILESDIR}"/bluealsa-conf.d bluealsa
+ newconfd "${FILESDIR}"/bluealsa-conf.d-2 bluealsa
}
pkg_postinst() {
diff --git a/media-sound/bluez-alsa/files/bluealsa-conf.d-2 b/media-sound/bluez-alsa/files/bluealsa-conf.d-2
new file mode 100644
index 000000000000..29d52f4a1fc4
--- /dev/null
+++ b/media-sound/bluez-alsa/files/bluealsa-conf.d-2
@@ -0,0 +1,4 @@
+# Config file for /etc/init.d/bluealsa
+
+# Allow additional options to be set
+BLUEALSA_CONF=""