summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-12-20 18:57:21 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-12-20 18:57:58 +0100
commit81434d56ebbd17a4e38fedbaade9e883d1f6d650 (patch)
treefef0fdc76b5884d76512b50187772ceb4f7891f5 /media-sound/bluez-alsa
parentcuda.eclass: fix 'gcc-bindir -f' output to not use '=' in opt (diff)
downloadgentoo-81434d56ebbd17a4e38fedbaade9e883d1f6d650.tar.gz
gentoo-81434d56ebbd17a4e38fedbaade9e883d1f6d650.tar.bz2
gentoo-81434d56ebbd17a4e38fedbaade9e883d1f6d650.zip
media-sound/bluez-alsa: Added multilib support to live ebuild (bug #603200).
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-sound/bluez-alsa')
-rw-r--r--media-sound/bluez-alsa/bluez-alsa-9999.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/media-sound/bluez-alsa/bluez-alsa-9999.ebuild b/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
index 630c8af31a98..263c3be8e5d1 100644
--- a/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
+++ b/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
@@ -3,7 +3,7 @@
# $Id$
EAPI=6
-inherit autotools eutils
+inherit autotools eutils multilib-minimal
DESCRIPTION="Bluetooth Audio ALSA Backend"
HOMEPAGE="https://github.com/Arkq/bluez-alsa"
@@ -20,17 +20,17 @@ LICENSE="MIT"
SLOT="0"
IUSE="aac debug hcitop"
-RDEPEND=">=dev-libs/glib-2.16[dbus]
- >=media-libs/alsa-lib-1.0
- >=media-libs/sbc-1.2
- >=net-wireless/bluez-5
+RDEPEND=">=dev-libs/glib-2.16[dbus,${MULTILIB_USEDEP}]
+ >=media-libs/alsa-lib-1.0[${MULTILIB_USEDEP}]
+ >=media-libs/sbc-1.2[${MULTILIB_USEDEP}]
+ >=net-wireless/bluez-5[${MULTILIB_USEDEP}]
+ aac? ( >=media-libs/fdk-aac-0.1.1[${MULTILIB_USEDEP}] )
hcitop? (
dev-libs/libbsd
sys-libs/ncurses:0=
)"
DEPEND="${RDEPEND}
net-libs/ortp
- aac? ( >=media-libs/fdk-aac-0.1.1 )
virtual/pkgconfig"
src_prepare() {
@@ -38,14 +38,15 @@ src_prepare() {
eautoreconf
}
-src_configure() {
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
econf \
$(use_enable aac) \
$(use_enable debug) \
- $(use_enable hcitop)
+ $(multilib_native_use_enable hcitop)
}
-src_install() {
+multilib_src_install_all() {
default
prune_libtool_files --modules