summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-10-18 10:09:18 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-10-18 10:09:46 +0200
commit948ee771c65417ab41ec2d41fbe32a12a7673dd8 (patch)
tree5e9ca8e9695cfe22394c917763e3d5e30b06ffd4 /media-sound/bluez-alsa
parentUpdate nano to 2.7.0. Should fix at least Bug #592572. (diff)
downloadgentoo-948ee771c65417ab41ec2d41fbe32a12a7673dd8.tar.gz
gentoo-948ee771c65417ab41ec2d41fbe32a12a7673dd8.tar.bz2
gentoo-948ee771c65417ab41ec2d41fbe32a12a7673dd8.zip
media-sound/bluez-alsa: Initial commit (bug #592310).
Kudos to Arkadiusz Bokowy (bug, ebuild, init script) and to Sander Sweers (ebuild, init script). Package-Manager: portage-2.3.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-sound/bluez-alsa')
-rw-r--r--media-sound/bluez-alsa/Manifest1
-rw-r--r--media-sound/bluez-alsa/bluez-alsa-1.1.0.ebuild50
-rw-r--r--media-sound/bluez-alsa/bluez-alsa-9999.ebuild52
-rw-r--r--media-sound/bluez-alsa/files/bluealsa-init.d18
-rw-r--r--media-sound/bluez-alsa/metadata.xml11
5 files changed, 132 insertions, 0 deletions
diff --git a/media-sound/bluez-alsa/Manifest b/media-sound/bluez-alsa/Manifest
new file mode 100644
index 000000000000..17dfe12c6237
--- /dev/null
+++ b/media-sound/bluez-alsa/Manifest
@@ -0,0 +1 @@
+DIST bluez-alsa-1.1.0.tar.gz 73676 SHA256 93396e581c196f9283d5907c7b8059ded21f5ec75a58f1c96f01d9ba295f5179 SHA512 167fa45994b57b0b44d5827762638d36ef782d7789c229e5c1ca99b59c13636dc53161cd45bec41e61890acd38b44d20778bc2085385582329a1c666530b21f1 WHIRLPOOL 2faba9fbd57fac2a519fe382c8a98654159a51819fea11da93ea3e198d31e51d3357bf2effa9df31713c2f201717dbd395a721efa81c9000a4da15df7e542a70
diff --git a/media-sound/bluez-alsa/bluez-alsa-1.1.0.ebuild b/media-sound/bluez-alsa/bluez-alsa-1.1.0.ebuild
new file mode 100644
index 000000000000..20e4c0d30b5e
--- /dev/null
+++ b/media-sound/bluez-alsa/bluez-alsa-1.1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="Bluetooth Audio ALSA Backend"
+HOMEPAGE="https://github.com/Arkq/bluez-alsa"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Arkq/${PN}"
+else
+ SRC_URI="https://github.com/Arkq/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.16[dbus]
+ >=media-libs/alsa-lib-1.0
+ >=media-libs/sbc-1.2
+ >=net-wireless/bluez-5"
+DEPEND="${RDEPEND}
+ net-libs/ortp
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+
+ newinitd "${FILESDIR}"/bluealsa-init.d bluealsa
+}
+
+pkg_postinst() {
+ elog "Users can use this service when they are members of the \"audio\" group."
+}
diff --git a/media-sound/bluez-alsa/bluez-alsa-9999.ebuild b/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
new file mode 100644
index 000000000000..35d35a0ce666
--- /dev/null
+++ b/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="Bluetooth Audio ALSA Backend"
+HOMEPAGE="https://github.com/Arkq/bluez-alsa"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Arkq/${PN}"
+else
+ SRC_URI="https://github.com/Arkq/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="aac debug"
+
+RDEPEND=">=dev-libs/glib-2.16[dbus]
+ >=media-libs/alsa-lib-1.0
+ >=media-libs/sbc-1.2
+ >=net-wireless/bluez-5"
+DEPEND="${RDEPEND}
+ net-libs/ortp
+ aac? ( >=media-libs/fdk-aac-0.1.1 )
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable aac) \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+
+ newinitd "${FILESDIR}"/bluealsa-init.d bluealsa
+}
+
+pkg_postinst() {
+ elog "Users can use this service when they are members of the \"audio\" group."
+}
diff --git a/media-sound/bluez-alsa/files/bluealsa-init.d b/media-sound/bluez-alsa/files/bluealsa-init.d
new file mode 100644
index 000000000000..1e2b2a70ab46
--- /dev/null
+++ b/media-sound/bluez-alsa/files/bluealsa-init.d
@@ -0,0 +1,18 @@
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+pidfile="/var/run/bluealsa.pid"
+command="/usr/bin/bluealsa"
+command_args="--disable-hsp"
+command_background="true"
+
+depend() {
+ after bluetooth
+ need dbus localmount
+}
+
+start_pre() {
+ checkpath -q -D -m 0700 -o :audio /var/run/bluealsa
+}
diff --git a/media-sound/bluez-alsa/metadata.xml b/media-sound/bluez-alsa/metadata.xml
new file mode 100644
index 000000000000..515507bad52a
--- /dev/null
+++ b/media-sound/bluez-alsa/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Arkq/bluez-alsa</remote-id>
+ </upstream>
+</pkgmetadata>